Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a solid working network and internet connection through eth0, but network manager still automatically tries to connect to wifi. Since the wifi is unreliable, this is just trying and failing over and over again, but even with decent wifi, I don't want both connections.

How do I configure it to not attempt to connect wlan0 if eth0 is connected?

# NetworkManager.conf:
[main]
plugins=ifupdown,keyfile
dns=dnsmasq

[ifupdown]
managed=false
share|improve this question
add comment

1 Answer 1

Please click the Network Manager icon and uncheck 'Enable Wireless.' Please check here: enter image description here

share|improve this answer
    
Yes, I could turn off the wifi antenna, but I shouldn't have to. Network manager used to be much better about trying the wifi while connected to ethernet, but nowadays it just keeps trying and trying when it can't succeed and doesn't need to. –  reasgt Aug 15 '13 at 22:31
    
Is your NetworkManager.conf file as installed by default or edited? –  chili555 Aug 15 '13 at 23:36
    
It's default from the package manager. I added it to my question, above. –  reasgt Aug 17 '13 at 7:13
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.