Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've just installed Ubuntu 12.04 yesterday, and i'm having problems watching video's on YouTube. Once I get to full screen the frame rate drops to 16fps. My PC runs the latest games on very high, so I don't think my hardware would be a problem.

I'm using Chromium, but Firefox has the same issue.

Other flash based streaming videos work fine (like twitch.tv). It's the same low frame rate between HTML5 and Flash.

Basically it's a Youtube problem and not a flash issue.

share|improve this question
    
have you installed the drivers for your graphic card? –  Alvar Aug 14 '13 at 11:47
    
Yes i.imgur.com/8Ij7FYV.png –  Anonymous Aug 14 '13 at 11:55
    
Some more information: switching to HTML5 didn't help and other flash-based video players, such as twitch.tv, work fine. –  Anonymous Aug 14 '13 at 12:45
    
okey, this is youtube only with flash/html5 having the same issue... cool –  Alvar Aug 14 '13 at 12:49
    
You may edit your question when you have more information or want to change it, rather than adding comments. –  Alvar Aug 14 '13 at 12:51

4 Answers 4

Maybe this helps, but I'm not sure.

Switch to full screen and click the right mouse button and then click on Configurations and try to activate or deactivate graphic acceleration.

I once had problems with YouTube and this solved it.

share|improve this answer
    
Didn't help. I believe I read somewhere that that's not supported on Linux. –  Anonymous Aug 14 '13 at 14:04

I think I found it. It's because google chrome using 2 flash plugins.

  1. Open up Google Chrome and in the address bar type chrome://plugins/

  2. You will then see a Details link over to the right-hand side of the page. Click the + and you’ll see a long list of the installed plugins in detail.

  3. Look in the Flash section and find the line which has the text ../pepflashplayer.so Click the Disable link next to this line and restart the browser.

In last step I actually need only reload YouTube page :)

Full description: http://rextronics.co.uk/general/how-to-fix-jerky-full-screen-youtube-videos-in-google-chrome/

share|improve this answer
    
This is actually for Windows. You'll want to look for /libpepflashplayer.so in step 3 instead. –  minerz029 Jan 8 at 23:51
    
I even didn't spot .dll ending :) but I assume everybody can realise it.. –  sobi3ch Jan 9 at 8:16

Sadly Adobe Flash 11.2 has a blacklist of graphics cards which it will not allow to use hardware acceleration, even with a good card, so it's just luck if yours is supported and on the white list...

You could try installing MiniTube and gstreamer0.10-ffmpeg which allows you to search and play YouTube videos full screen using system codecs instead of the flash player...

share|improve this answer
    
You'll want to ensure the appropriate packages for hardware acceleration are installed as well, in my case I needed 'i965-va-driver' to enable Intel video acceleration. I'd add 'vainfo' as well so you can verify that acceleration is working. –  Veazer Oct 26 at 3:31

Try using SMPlayer with the SMTube, which will allow you to watch YouTube videos without using HTML5 or Flash (it uses MPlayer, which is much faster than Flash). You can try a number of output drivers, to see which one works best (xv works great for me).

To install SMPlayer, run the following

sudo add-apt-repository
sudo apt-get update
sudo apt-get install smplayer smtube
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.