Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am a Windows user, but want to use Ubuntu now.

For this I have downloaded Ubuntu 64-bit from the Ubuntu site. But, I am not able to install it. I have tried both, booting from it as to clean install and through Wubi.

While booting from Ubuntu, all I got was a black screen with a circle, an '=' image and small human like image. It remains there for a while and thereafter an error message Uncompression failed -- System Halted appears and system reboot.

Here are last few lines of error log:

08-14 15:58 ERROR  TaskList: Non fatal error [Errno 4] IOError: <urlopen error (7, 'getaddrinfo failed')> in task download
08-14 15:58 DEBUG  TaskList: ### Finished download
08-14 15:58 ERROR  TaskList: Could not retrieve the required disk image files
Traceback (most recent call last):
  File "\lib\wubi\backends\common\", line 197, in __call__
  File "\lib\wubi\backends\common\", line 592, in get_diskimage
Exception: Could not retrieve the required disk image files
08-14 15:58 DEBUG  TaskList: # Cancelling tasklist
08-14 15:58 DEBUG  TaskList: # Finished tasklist
08-14 15:58 ERROR  root: Could not retrieve the required disk image files
Traceback (most recent call last):
  File "\lib\wubi\", line 58, in run
  File "\lib\wubi\", line 132, in select_task
  File "\lib\wubi\", line 158, in run_installer
  File "\lib\wubi\backends\common\", line 197, in __call__
  File "\lib\wubi\backends\common\", line 592, in get_diskimage
Exception: Could not retrieve the required disk image files

While trying with Wubi, it gives error Could not retrieve the required disk image files. Whereas I have complete Ubuntu desktop installed.

Please guide me through this as I really want to move to Ubuntu.

Please do not suggest that I have to download it again, as I have a very slow data connection.

One thing I would like to share, is that I didn't downloaded the setup in one go, but many a times by resuming as my net connection is very bad.

My laptop is Dell Inspiron 3521 with Windows 7 Ultimate 32-bit trial version is installed in it. But it is of 64 bit architecture.

EDIT: Just checked on my other desktop and it has same problem. Though my desktop is of 32 bit architecture, so there had to be incompatibilty. Do you think it could be because OS on my laptop is 32 bit or trial version?????

share|improve this question

marked as duplicate by Eliah Kagan, Lucio, Warren Hill, Eric Carvalho, muru Aug 18 '14 at 18:05

This question was marked as an exact duplicate of an existing question.

Check the md5sum of the ISO to make sure it downloaded okay. If it's bad it won't work. – bcbc Aug 14 '13 at 13:42
Checked and verified. MD5 Checksum of my downloaded file is: b436b6d4c7de064652f30d783bda5b4e Same as given on ubuntu hash pages Now, what should I do :-( – user183997 Aug 15 '13 at 3:42
Check the MD5sum on the DVD or USB that you are trying to use to Verify burned .iso. on installation media. When booting installation media this should be an option also when booting from .iso. Press any key if you see purple screen with two icons at bottom select language and select Verify Disc. WUBI does have its advantages when it does work but the most beneficial method of installing is a clean install to unallocated space following the on screen instruction as you go. – geezanansa Aug 15 '13 at 4:25
So for Wubi, place the ISO and the wubi.exe from in the same folder before running Wubi. Not sure what the USB install problem is, but I'd try redoing is as described here. It's better if you provide the whole Wubi log file because there is a lot of info that helps diagnose problems. – bcbc Aug 15 '13 at 13:38

Ok. Thanks bcbc, and geezanansa for taking time to replying. The problem is solved now. I think the problem was in CD with which I was booting, i just burned it on an USB and booted from there and it installed. Though don't know, why WUBI wasn't working. I think because my existing OS was 32 bit.

Anyways, I have installed ubuntu and this is my first time, using ubuntu (or any Linux distro), till now its good. Will ask for help in case of difficulty :-)

P.S.: I am the asker (Abhishek) only, but have two accounts here. Can ayone tell, how can I delete my this one and use my above (Abhishek) username id?????????

share|improve this answer