Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I have tried to install Ubuntu on a Macbook Air 6,2 without any success.

I installed refit and from within macos deceased the mac partition. In order to create a boot medium, I followed the section "Manual Approach" in this guide. Newer Ubuntu images do not boot all the way, which I am relating to this bug.

The only image I tried that booted all the way is 12.04. However, in the installation process, I could not manage to proceed past the following dialogue:

Preparing to Install Ubuntu

After a few moments, instead of the expected next dialogue window, the following is displayed:

some console output

and then nothing changes.

Is this even related to the Kernel bug, or how do I find out? How am i supposed to proceed? Has anyone successfully installed Ubuntu on a Macbook Air 6,2 ?

share|improve this question
This seems like a kernel problem (after searching online), but did you try connecting to internet? – Jeremy Aug 15 '13 at 14:48
@Waza_Be for the wifi solution, you need to install the braodcom package for wifi and here is the link here is another link for detailed steps:… – user272878 Apr 23 '14 at 6:48

2 Answers 2

I have successfully installed 12.04 on my MacBook Air 6,2 following this this guide.

I have installed reFind rather than reFit.

share|improve this answer
Wi-fi does not work out of the box, guides can be found to fix it, try tethering by USB for the interem – Christian Aug 29 '13 at 6:36
I have been searching for wifi fixes, but cannot find anything, except this post.. Maybe you can help and give some links – Waza_Be Jan 23 '14 at 13:18
@Waza_Be: the new live ubuntu on usb (15.04) has the driver. you have to enable it by using the "additional drivers" (type it in Dash). then you can install from the machine booted on the live usb disk. – krumpelstiltskin May 28 at 8:18

so after you clicked continue (from the first image) if that (second image) is what you see .. then its probably that you downloaded a bad ISO file .. try re downloading Ubuntu from the official webpage ..

and you could follow this tutorial .that is how i installed ubuntu on my MBA 6,2 .

  • make sure you download 64-bit version
  • i've tried 14.04 as well as 15.10 .. both installed fine ..
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.