Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to install vlc on my Gateway netbook running 12.04 through wubi but whether I try using terminal or the software center I get this error message.

The following packages have unmet dependencies:
vlc : Depends: vlc-nox (= 2.0.8+git20130809+r605-0~r43~precise1) but it is not going to be installed
   Depends: libavcodec53 (>= 4:0.8-1~) but it is not going to be installed or
            libavcodec-extra-53 (>= 4:0.8-1~) but it is not going to be installed
   Depends: libsdl-image1.2 (>= 1.2.10) but it is not installable
   Depends: libtar0 but it is not installable
   Depends: libva-x11-1 (> 1.0.15~) but it is not installable
   Depends: libva1 (> 1.0.15~) but it is not installable
   Depends: libxcb-keysyms1 (>= 0.3.8) but it is not installable
   Recommends: vlc-plugin-notify (= 2.0.8+git20130809+r605-0~r43~precise1) but it is not going to be installed
   Recommends: vlc-plugin-pulse (= 2.0.8+git20130809+r605-0~r43~precise1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I have spent a good hour on google and the forums trying to resolve this but nothing seems to be working. I have tried using the daily releases ppa. I tried this...

sudo apt-get install --fix-broken && sudo apt-get autoremove && sudo apt-get update && sudo apt-get install vlc

...but it didn't change anything along with the other methods posted on the forums. I updated just before trying to download vlc but vlc would not download before the update either.

Any responses would be much appreciated.

edit Here is the info you wanted.

vlc-data:
  Installed: (none)
  Candidate: 2.0.8+git20130809+r605-0~r43~precise1
  Version table:
     2.0.8+git20130809+r605-0~r43~precise1 0
        500 http://ppa.launchpad.net/videolan/stable-daily/ubuntu/ precise/main i386 Packages
     2.0.8-0ubuntu0.12.04.1 0
        500 http://archive.ubuntu.com/ubuntu/ precise-updates/universe i386 Packages
        500 http://archive.ubuntu.com/ubuntu/ precise-security/universe i386 Packages
     2.0.1-4 0
        500 http://archive.ubuntu.com/ubuntu/ precise/universe i386 Packages
vlc:
  Installed: (none)
  Candidate: 2.0.8+git20130809+r605-0~r43~precise1
  Version table:
     2.0.8+git20130809+r605-0~r43~precise1 0
        500 http://ppa.launchpad.net/videolan/stable-daily/ubuntu/ precise/main i386 Packages
     2.0.8-0ubuntu0.12.04.1 0
        500 http://archive.ubuntu.com/ubuntu/ precise-updates/universe i386 Packages
    500 http://archive.ubuntu.com/ubuntu/ precise-security/universe i386 Packages
 2.0.1-4 0
    500 http://archive.ubuntu.com/ubuntu/ precise/universe i386 Packages
vlc-nox:
  Installed: (none)
  Candidate: 2.0.8+git20130809+r605-0~r43~precise1
  Version table:
     2.0.8+git20130809+r605-0~r43~precise1 0
        500 http://ppa.launchpad.net/videolan/stable-daily/ubuntu/ precise/main i386 Packages
     2.0.8-0ubuntu0.12.04.1 0
        500 http://archive.ubuntu.com/ubuntu/ precise-updates/universe i386 Packages
        500 http://archive.ubuntu.com/ubuntu/ precise-security/universe i386 Packages
     2.0.1-4 0
        500 http://archive.ubuntu.com/ubuntu/ precise/universe i386 Packages
libvlccore5:
  Installed: (none)
  Candidate: 2.0.8+git20130809+r605-0~r43~precise1
  Version table:
     2.0.8+git20130809+r605-0~r43~precise1 0
        500 http://ppa.launchpad.net/videolan/stable-daily/ubuntu/ precise/main i386 Packages 
     2.0.8-0ubuntu0.12.04.1 0
        500 http://archive.ubuntu.com/ubuntu/ precise-updates/universe i386 Packages
        500 http://archive.ubuntu.com/ubuntu/ precise-security/universe i386 Packages
     2.0.1-4 0
        500 http://archive.ubuntu.com/ubuntu/ precise/universe i386 Packages
libvlc5:
  Installed: (none)
  Candidate: 2.0.8+git20130809+r605-0~r43~precise1
  Version table:
     2.0.8+git20130809+r605-0~r43~precise1 0
        500 http://ppa.launchpad.net/videolan/stable-daily/ubuntu/ precise/main i386 Packages
     2.0.8-0ubuntu0.12.04.1 0
        500 http://archive.ubuntu.com/ubuntu/ precise-updates/universe i386 Packages
        500 http://archive.ubuntu.com/ubuntu/ precise-security/universe i386 Packages
     2.0.1-4 0
        500 http://archive.ubuntu.com/ubuntu/ precise/universe i386 Packages`

thanks for the help.

share|improve this question
    
post the results of apt-cache policy vlc-data vlc vlc-nox libvlccore5 libvlc5 –  doug Aug 13 '13 at 22:26
    
@doug output added by the way. –  Alaa Aug 13 '13 at 22:40
add comment

1 Answer 1

Try running:

sudo apt-get update

Then: sudo apt-get install vlc

In the terminal

share|improve this answer
    
Hi! In the question, it is already mentioned that he tried to do that. –  Alaa Aug 13 '13 at 22:38
    
Yes, I tried that before and it hasn't worked –  mico5367314563 Aug 13 '13 at 22:40
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.