Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This is what I get when I run sudo apt-get install g++:

libgtksourceview-3.0-0 is already the newest version.
libgconf-2-4 is already the newest version.
ibus-gtk is already the newest version.
libqtgui4 is already the newest version.
libgssapi-krb5-2 is already the newest version.
ubuntu-extras-keyring is already the newest version.
libpam0g is already the newest version.
libclutter-gtk-1.0-0 is already the newest version.
libgpg-error0 is already the newest version.
libdbusmenu-glib4 is already the newest version.
gir1.2-atspi-2.0 is already the newest version.
perl-modules is already the newest version.
lightdm-remote-session-uccsconfigure is already the newest version.
libcolorhug1 is already the newest version.
gedit-common is already the newest version.
libwebkitgtk-3.0-common is already the newest version.
system-config-printer-gnome is already the newest version.
libgcc-4.7-dev is already the newest version.
libtelepathy-logger3 is already the newest version.
fonts-tlwg-loma is already the newest version.
account-plugin-yahoo is already the newest version.
firefox-globalmenu is already the newest version.
libgpod4 is already the newest version.
libgail-3-0 is already the newest version.
fonts-tlwg-umpush is already the newest version.
xdg-user-dirs-gtk is already the newest version.
libgudev-1.0-0 is already the newest version.
libgtksourceview-3.0-common is already the newest version.
apport-gtk is already the newest version.
intel-gpu-tools is already the newest version.
libcanberra-gtk-module is already the newest version.
gnome-system-log is already the newest version.
account-plugin-jabber is already the newest version.
libproxy1-plugin-networkmanager is already the newest version.
libgweather-3-1 is already the newest version.
libdmapsharing-3.0-2 is already the newest version.
gir1.2-soup-2.4 is already the newest version.
language-selector-gnome is already the newest version.
account-plugin-google is already the newest version.
modemmanager is already the newest version.
python-gi is already the newest version.
libglib2.0-data is already the newest version.
libgdk-pixbuf2.0-0 is already the newest version.
xorg is already the newest version.
fonts-lklug-sinhala is already the newest version.
libtelepathy-glib0 is already the newest version.
libgrip0 is already the newest version.
libsignon-qt1 is already the newest version.
ubuntu-settings is already the newest version.
language-pack-gnome-en-base is already the newest version.
zeitgeist-core is already the newest version.
branding-ubuntu is already the newest version.
gstreamer1.0-plugins-base is already the newest version.
apg is already the newest version.
thunderbird-globalmenu is already the newest version.
gnome-icon-theme-symbolic is already the newest version.
policykit-desktop-privileges is already the newest version.
sgml-base is already the newest version.
libdigest-hmac-perl is already the newest version.
unity-scope-gdrive is already the newest version.
libsignon-extension1 is already the newest version.
gir1.2-totem-plparser-1.0 is already the newest version.
session-migration is already the newest version.
libunistring0 is already the newest version.
libdbus-glib-1-2 is already the newest version.
gir1.2-totem-1.0 is already the newest version.
libgstreamer-plugins-good1.0-0 is already the newest version.
manpages-dev is already the newest version.
telepathy-gabble is already the newest version.
grub-common is already the newest version.
account-plugin-twitter is already the newest version.
liblangtag-common is already the newest version.
libgc1c3 is already the newest version.
gedit is already the newest version.
libgrail6 is already the newest version.
xserver-xorg-core is already the newest version.
libgdata13 is already the newest version.
libgupnp-igd-1.0-4 is already the newest version.
glib-networking is already the newest version.
syslinux-legacy is already the newest version.
gir1.2-packagekitglib-1.0 is already the newest version.
libmagic1 is already the newest version.
libgcr-3-common is already the newest version.
signond is already the newest version.
libgoa-1.0-0 is already the newest version.
xserver-xorg-video-openchrome is already the newest version.
libpam-xdg-support is already the newest version.
ntfs-3g is already the newest version.
libpulse-mainloop-glib0 is already the newest version.
gir1.2-gst-plugins-base-1.0 is already the newest version.
libwebkitgtk-3.0-0 is already the newest version.
libelfg0 is already the newest version.
activity-log-manager-control-center is already the newest version.
xserver-xorg-video-vmware is already the newest version.
gnome-contacts is already the newest version.
libavahi-glib1 is already the newest version.
python is already the newest version.
gir1.2-dee-1.0 is already the newest version.
rhythmbox-plugins is already the newest version.
gettext is already the newest version.
libfontconfig1 is already the newest version.
xserver-xorg-input-wacom is already the newest version.
libsemanage1 is already the newest version.
systemd-services is already the newest version.
grub-pc-bin is already the newest version.
ssh-askpass-gnome is already the newest version.
activity-log-manager-common is already the newest version.
libxxf86dga1 is already the newest version.
gnome-accessibility-themes is already the newest version.
libogg0 is already the newest version.
xserver-xorg-video-radeon is already the newest version.
geoclue is already the newest version.
libdpkg-perl is already the newest version.
libsgutils2-2 is already the newest version.
gvfs-backends is already the newest version.
libqt4-svg is already the newest version.
libgtop2-7 is already the newest version.
xserver-xorg-video-qxl is already the newest version.
gnome-control-center-data is already the newest version.
gir1.2-javascriptcoregtk-3.0 is already the newest version.
xserver-xorg-video-savage is already the newest version.
libapt-pkg4.12 is already the newest version.
xserver-xorg-video-fbdev is already the newest version.
software-center is already the newest version.
zeitgeist is already the newest version.
libgstreamer-plugins-base0.10-0 is already the newest version.
libgtk2.0-0 is already the newest version.
libpolkit-agent-1-0 is already the newest version.
libtag1-vanilla is already the newest version.
xserver-xorg-input-evdev is already the newest version.
gconf2-common is already the newest version.
gir1.2-gnomebluetooth-1.0 is already the newest version.
remmina-plugin-vnc is already the newest version.
python3-gi is already the newest version.
python3-xdg is already the newest version.
gir1.2-atk-1.0 is already the newest version.
gnome-keyring is already the newest version.
libgnome-keyring-common is already the newest version.
libgettextpo0 is already the newest version.
gir1.2-networkmanager-1.0 is already the newest version.
gcc-4.7 is already the newest version.
gnome-mines is already the newest version.
gir1.2-webkit-3.0 is already the newest version.
python-aptdaemon.gtk3widgets is already the newest version.
geoclue-ubuntu-geoip is already the newest version.
ubuntu-sso-client-qt is already the newest version.
zlib1g is already the newest version.
libcloog-ppl1 is already the newest version.
gnome-sudoku is already the newest version.
xserver-xorg is already the newest version.
libapt-pkg-perl is already the newest version.
libcanberra-gtk3-module is already the newest version.
gnome-font-viewer is already the newest version.
libglu1-mesa is already the newest version.
gsfonts is already the newest version.
fonts-tlwg-purisa is already the newest version.
xserver-xorg-video-all is already the newest version.
update-manager-core is already the newest version.
gir1.2-gmenu-3.0 is already the newest version.
gstreamer1.0-tools is already the newest version.
network-manager-pptp is already the newest version.
python3-update-manager is already the newest version.
manpages is already the newest version.
policykit-1-gnome is already the newest version.
libpython3.3-stdlib is already the newest version.
pppconfig is already the newest version.
libgcc1 is already the newest version.
gtk3-engines-unico is already the newest version.
gvfs-common is already the newest version.
bluez-gstreamer is already the newest version.
linux-image-3.8.0-19-generic is already the newest version.
libneon27-gnutls is already the newest version.
libgirepository-1.0-1 is already the newest version.
libreoffice-gnome is already the newest version.
gir1.2-gstreamer-1.0 is already the newest version.
libgpgme11 is already the newest version.
gir1.2-gst-plugins-base-0.10 is already the newest version.
gnome-session-canberra is already the newest version.
poppler-data is already the newest version.
system-config-printer-udev is already the newest version.
libasound2-plugins is already the newest version.
libcogl-common is already the newest version.
libcairo-gobject2 is already the newest version.
gstreamer1.0-x is already the newest version.
libmission-control-plugins0 is already the newest version.
libgtk-3-0 is already the newest version.
libcanberra-gtk3-0 is already the newest version.
libgdata-common is already the newest version.
xserver-xorg-input-synaptics is already the newest version.
xserver-xorg-video-vesa is already the newest version.
ubuntu-wallpapers-raring is already the newest version.
lockfile-progs is already the newest version.
gnome-menus is already the newest version.
libglib-perl is already the newest version.
libegl1-mesa-drivers is already the newest version.
ubuntuone-control-panel-qt is already the newest version.
gir1.2-messagingmenu-1.0 is already the newest version.
libjpeg-turbo8 is already the newest version.
logrotate is already the newest version.
plymouth-theme-ubuntu-logo is already the newest version.
gnome-session-common is already the newest version.
libpam-gnome-keyring is already the newest version.
ubuntuone-client-gnome is already the newest version.
gnome-control-center is already the newest version.
gsettings-desktop-schemas is already the newest version.
gnome-calculator is already the newest version.
gconf-service-backend is already the newest version.
libpango1.0-0 is already the newest version.
libjbig0 is already the newest version.
xserver-xorg-video-sisusb is already the newest version.
gir1.2-rb-3.0 is already the newest version.
genisoimage is already the newest version.
gnome-icon-theme is already the newest version.
libupower-glib1 is already the newest version.
libgeis1 is already the newest version.
libgtk2.0-common is already the newest version.
xserver-xorg-video-tdfx is already the newest version.
libxcb-glx0 is already the newest version.
libglapi-mesa is already the newest version.
python-gobject-2 is already the newest version.
guile-2.0-libs is already the newest version.
fonts-tlwg-kinnari is already the newest version.
dictionaries-common is already the newest version.
libgs9 is already the newest version.
gnome-session is already the newest version.
libgstreamer1.0-0 is already the newest version.
gir1.2-pango-1.0 is already the newest version.
fonts-tlwg-typewriter is already the newest version.
telepathy-logger is already the newest version.
wget is already the newest version.
libgl1-mesa-glx is already the newest version.
gir1.2-gdata-0.0 is already the newest version.
transmission-gtk is already the newest version.
libdbusmenu-gtk3-4 is already the newest version.
libgexiv2-2 is already the newest version.
libgnome-menu-3-0 is already the newest version.
gstreamer1.0-alsa is already the newest version.
gstreamer1.0-clutter is already the newest version.
libqt4-opengl is already the newest version.
librsvg2-2 is already the newest version.
gir1.2-gudev-1.0 is already the newest version.
language-pack-en-base is already the newest version.
libnm-gtk-common is already the newest version.
gnome-orca is already the newest version.
libgtk2-perl is already the newest version.
gnome-bluetooth is already the newest version.
libpoppler-glib8 is already the newest version.
groff-base is already the newest version.
thunderbird-gnome-support is already the newest version.
gnupg is already the newest version.
gir1.2-ebook-1.2 is already the newest version.
xserver-xorg-video-cirrus is already the newest version.
account-plugin-flickr is already the newest version.
libaccounts-glib0 is already the newest version.
libgmime-2.6-0 is already the newest version.
libgail18 is already the newest version.
xul-ext-websites-integration is already the newest version.
account-plugin-windows-live is already the newest version.
wireless-regdb is already the newest version.
signon-plugin-password is already the newest version.
gir1.2-notify-0.7 is already the newest version.
libgutenprint2 is already the newest version.
xserver-xorg-video-r128 is already the newest version.
im-config is already the newest version.
xdg-utils is already the newest version.
unattended-upgrades is already the newest version.
libgusb2 is already the newest version.
ubuntu-release-upgrader-core is already the newest version.
fonts-tlwg-typist is already the newest version.
libgs9-common is already the newest version.
grep is already the newest version.
fonts-tlwg-garuda is already the newest version.
gir1.2-edataserver-1.2 is already the newest version.
glib-networking-services is already the newest version.
libnl-genl-3-200 is already the newest version.
libavahi-gobject0 is already the newest version.
ghostscript-x is already the newest version.
python3-gdbm is already the newest version.
linux-image-generic is already the newest version.
libqt4-designer is already the newest version.
libxdamage1 is already the newest version.
keyboard-configuration is already the newest version.
xserver-xorg-video-neomagic is already the newest version.
libmng1 is already the newest version.
printer-driver-gutenprint is already the newest version.
libgnomekbd-common is already the newest version.
gvfs-libs is already the newest version.
libgdk-pixbuf2.0-common is already the newest version.
libcogl-pango12 is already the newest version.
python-gnomekeyring is already the newest version.
geoip-database is already the newest version.
libjpeg8 is already the newest version.
librsvg2-common is already the newest version.
sessioninstaller is already the newest version.
libcompizconfig0 is already the newest version.
xdg-user-dirs is already the newest version.
libgstreamer0.10-0 is already the newest version.
gnome-disk-utility is already the newest version.
xserver-xorg-video-modesetting is already the newest version.
gir1.2-gtksource-3.0 is already the newest version.
libsignon-plugins-common1 is already the newest version.
libslang2 is already the newest version.
unity-lens-shopping is already the newest version.
libgeoclue0 is already the newest version.
linux-headers-3.8.0-19-generic is already the newest version.
libsemanage-common is already the newest version.
libgck-1-0 is already the newest version.
gucharmap is already the newest version.
liblightdm-gobject-1-0 is already the newest version.
libopenvg1-mesa is already the newest version.
libgweather-common is already the newest version.
libgail-common is already the newest version.
xserver-xorg-video-nouveau is already the newest version.
xfonts-encodings is already the newest version.
libgtk-3-bin is already the newest version.
gnome-terminal-data is already the newest version.
libclutter-gst-2.0-0 is already the newest version.
libgxps2 is already the newest version.
fonts-tlwg-mono is already the newest version.
mcp-account-manager-uoa is already the newest version.
gconf-service is already the newest version.
grub-gfxpayload-lists is already the newest version.
gir1.2-accounts-1.0 is already the newest version.
libpangomm-1.4-1 is already the newest version.
python-gtk2 is already the newest version.
e2fsprogs is already the newest version.
python-gi-cairo is already the newest version.
libpaper1 is already the newest version.
python-gobject is already the newest version.
libsigc++-2.0-0c2a is already the newest version.
libnm-gtk0 is already the newest version.
gvfs is already the newest version.
libglib2.0-bin is already the newest version.
libglibmm-2.4-1c2a is already the newest version.
printer-driver-sag-gdi is already the newest version.
gnomine is already the newest version.
libgnutls26 is already the newest version.
xserver-xorg-video-mga is already the newest version.
libgpm2 is already the newest version.
python3-distupgrade is already the newest version.
gstreamer1.0-nice is already the newest version.
gzip is already the newest version.
dpkg is already the newest version.
grub-pc is already the newest version.
gstreamer1.0-plugins-base-apps is already the newest version.
thin-client-config-agent is already the newest version.
pkg-config is already the newest version.
overlay-scrollbar-gtk3 is already the newest version.
overlay-scrollbar-gtk2 is already the newest version.
gnome-mahjongg is already the newest version.
appmenu-gtk is already the newest version.
firefox-gnome-support is already the newest version.
liblocale-gettext-perl is already the newest version.
ubuntu-keyring is already the newest version.
libsignon-glib1 is already the newest version.
glib-networking-common is already the newest version.
libcanberra-gtk0 is already the newest version.
gir1.2-freedesktop is already the newest version.
software-center-aptdaemon-plugins is already the newest version.
gstreamer0.10-pulseaudio is already the newest version.
libcap-ng0 is already the newest version.
gir1.2-wnck-3.0 is already the newest version.
gir1.2-signon-1.0 is already the newest version.
libproxy1-plugin-gsettings is already the newest version.
totem-plugins is already the newest version.
gnome-user-share is already the newest version.
gir1.2-glib-2.0 is already the newest version.
gcr is already the newest version.
gcc is already the newest version.
ghostscript is already the newest version.
python-xdg is already the newest version.
xserver-xorg-video-s3 is already the newest version.
dialog is already the newest version.
lightdm is already the newest version.
appmenu-gtk3 is already the newest version.
iputils-ping is already the newest version.
signon-keyring-extension is already the newest version.
python-ubuntuone-storageprotocol is already the newest version.
xserver-xorg-video-trident is already the newest version.
libgettextpo-dev is already the newest version.
libgssapi3-heimdal is already the newest version.
python-zeitgeist is already the newest version.
libwmf0.2-7-gtk is already the newest version.
xserver-xorg-video-intel is already the newest version.
perl is already the newest version.
gir1.2-gstreamer-0.10 is already the newest version.
libcogl12 is already the newest version.
indicator-messages is already the newest version.
libreoffice-ogltrans is already the newest version.
system-config-printer-common is already the newest version.
fonts-thai-tlwg is already the newest version.
xserver-xorg-video-mach64 is already the newest version.
libnm-glib4 is already the newest version.
network-manager is already the newest version.
libcupscgi1 is already the newest version.
libgtkmm-3.0-1 is already the newest version.
libfftw3-single3 is already the newest version.
gnome-desktop3-data is already the newest version.
language-pack-gnome-en is already the newest version.
libzeitgeist-1.0-1 is already the newest version.
gnome-screensaver is already the newest version.
gir1.2-unity-5.0 is already the newest version.
fonts-tlwg-norasi is already the newest version.
libtag1c2a is already the newest version.
libjbig2dec0 is already the newest version.
gkbd-capplet is already the newest version.
libgphoto2-2 is already the newest version.
python3-pkg-resources is already the newest version.
gstreamer0.10-gconf is already the newest version.
python-imaging is already the newest version.
rhythmbox-plugin-magnatune is already the newest version.
gcc-4.7-base is already the newest version.
python-debtagshw is already the newest version.
libgnome-bluetooth11 is already the newest version.
gnome-control-center-unity is already the newest version.
libgupnp-1.0-4 is already the newest version.
gconf2 is already the newest version.
python3-gi-cairo is already the newest version.
fonts-takao-pgothic is already the newest version.
account-plugin-aim is already the newest version.
libgoa-1.0-common is already the newest version.
gstreamer0.10-plugins-base is already the newest version.
libgphoto2-l10n is already the newest version.
libgstreamer-plugins-base1.0-0 is already the newest version.
libdbusmenu-gtk4 is already the newest version.
libpackagekit-glib2-14 is already the newest version.
libgnome-keyring0 is already the newest version.
xserver-xorg-input-all is already the newest version.
network-manager-pptp-gnome is already the newest version.
fontconfig-config is already the newest version.
libwpg-0.2-2 is already the newest version.
libegl1-mesa is already the newest version.
signon-ui is already the newest version.
dconf-gsettings-backend is already the newest version.
gir1.2-gdkpixbuf-2.0 is already the newest version.
linux-generic is already the newest version.
xserver-xorg-input-mouse is already the newest version.
remmina-plugin-rdp is already the newest version.
light-themes is already the newest version.
libfreerdp-plugins-standard is already the newest version.
libparse-debianchangelog-perl is already the newest version.
libgtk2.0-bin is already the newest version.
firefox is already the newest version.
libreoffice-gtk is already the newest version.
fonts-tlwg-sawasdee is already the newest version.
linux-headers-generic is already the newest version.
gnome-control-center-signon is already the newest version.
libpython2.7-stdlib is already the newest version.
libglewmx1.8 is already the newest version.
libaccount-plugin-1.0-0 is already the newest version.
libc6 is already the newest version.
language-selector-common is already the newest version.
ghostscript-cups is already the newest version.
gir1.2-dbusmenu-glib-0.4 is already the newest version.
rhythmbox-plugin-zeitgeist is already the newest version.
gvfs-daemons is already the newest version.
gir1.2-gnomekeyring-1.0 is already the newest version.
grub2-common is already the newest version.
zeitgeist-datahub is already the newest version.
gstreamer0.10-plugins-good is already the newest version.
libnm-glib-vpn1 is already the newest version.
libpng12-0 is already the newest version.
linux-image-extra-3.8.0-19-generic is already the newest version.
gir1.2-gtk-3.0 is already the newest version.
compiz-gnome is already the newest version.
libgee2 is already the newest version.
account-plugin-salut is already the newest version.
libgmp10 is already the newest version.
lightdm-remote-session-freerdp is already the newest version.
gir1.2-vte-2.90 is already the newest version.
xdiagnose is already the newest version.
update-manager is already the newest version.
libgbm1 is already the newest version.
libisccfg90 is already the newest version.
rhythmbox-plugin-cdrecorder is already the newest version.
gstreamer0.10-x is already the newest version.
libgucharmap-2-90-7 is already the newest version.
rsyslog is already the newest version.
libglew1.8 is already the newest version.
powermgmt-base is already the newest version.
network-manager-gnome is already the newest version.
libvisual-0.4-plugins is already the newest version.
account-plugin-generic-oauth is already the newest version.
iputils-arping is already the newest version.
hardening-includes is already the newest version.
pulseaudio is already the newest version.
gvfs-fuse is already the newest version.
xorg-docs-core is already the newest version.
xserver-xorg-video-ati is already the newest version.
xserver-xorg-video-siliconmotion is already the newest version.
gir1.2-appindicator3-0.1 is already the newest version.
libufe-xidgetter0 is already the newest version.
gstreamer0.10-alsa is already the newest version.
python-gconf is already the newest version.
gstreamer0.10-tools is already the newest version.
libgphoto2-port0 is already the newest version.
libglib2.0-0 is already the newest version.
gir1.2-peas-1.0 is already the newest version.
python-configglue is already the newest version.
libatk-bridge2.0-0 is already the newest version.
gnome-session-bin is already the newest version.
libgomp1 is already the newest version.
libmessaging-menu0 is already the newest version.
usb-creator-gtk is already the newest version.
libgnome-desktop-3-4 is already the newest version.
software-properties-gtk is already the newest version.
libcupsimage2 is already the newest version.
growisofs is already the newest version.
libio-string-perl is already the newest version.
gnome-power-manager is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

How do I install g++ now?

share|improve this question
3  
Please, next time, don't use caps ;) –  Braiam Aug 13 '13 at 13:00
1  
@rashik run g++ -v and do inform what it returns –  Stormvirux Aug 13 '13 at 17:07

2 Answers 2

It means that g++ is already installed!!

Linux comes with gcc already installed, so to compile your programs just use

g++ <filename>

If that doesnt work try

gcc <filename>

That should work.

share|improve this answer
1  
It is not correct that g++ comes preinstalled. While the default image does include gcc, it does not include g++. See releases.ubuntu.com/raring/ubuntu-13.04-desktop-amd64.manifest , for example. You first need to install g++ (or a metapackage like build-essential). –  chronitis Aug 13 '13 at 14:50
    
ok..i thought that gcc also contained g++, because when i typed in my terminal g++ it seemed to work, and i have no knowledge of installing it..and when the question asker tries to apt-get install g++ it shows all the packages are already installed, so doesnt it mean that g++ is also installed? Or will he have to do apt-get install build-essesntial ? –  Aaditya Bagga Aug 13 '13 at 15:24
    
looking at this post, gcc also seems to include g++ askubuntu.com/questions/248079/how-to-install-g-4-8?lq=1 –  Aaditya Bagga Aug 13 '13 at 15:37

Run:

sudo apt-get update

You should always run that before installing or upgrading packages on the command-line (unless you've run it very recently). It fetches information about what packages are available in what versions from where.

You may simply be able to install g++ now, Then try installing g++ again:

sudo apt-get install g++
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.