Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've recently bought a Packard Bell imedia S 2870 with Windows 8 on. After manually installing Ubuntu 13.04 ('something else' option), the PC would boot straight to Windows.

I tried to reinstall the grub via ChRoot--following instructions indicated in various forums: e.g. https://help.ubuntu.com/community/Grub2/Installing#Reinstalling_GRUB_2 (but to no avail)--and then, after, using Boot-Repair--I went for the reccomended repair settings--, which generated the following URL (http://paste.ubuntu.com/5978031/) and invited me to make my BIOS boot on the sda2/EFI/Ubuntu/shimx64.efi file. After rebooting, the error message in the subject line above appeared, and I was not able to set any such sda2/EFI/Ubuntu/shimx64.efi as the default boot device when I accessed the BIOS.

I have had a look at similar threads without finding anything fit for purpose.

Any suggestions? Thanks

share|improve this question
    
Thanks, Braiam. Gparted shows the 'boot' flag is already set on sda2. Is there any way I can set the above .efi file as default boot? Althernatively, would running Boot-Repair again be of any use? –  Salvo Aug 13 '13 at 12:58
1  
Please select the check-mark next to the answer that "solved" your question, not marking "solved" in question title. –  Mateo Sep 6 '13 at 17:28
add comment

2 Answers

up vote 2 down vote accepted

After reading several other threads and tinkering around – I installed efibootmgr at some point too -, I sorted the problem out by running Boot-Repair a second time (with Secure Boot off though), leaving all default settings, as per first time. The URL generated at the end of the process was http://paste.ubuntu.com/5982069/

Interestingly, I read somewhere that Ubuntu 13.04 is Secure Boot compatible; however, when I turned this feature back on and restarted the machine, I incurred in a ‘validation error’, and the system booted straight to Windows 8. I’ve therefore decided to leave it off for good!

Braiam and Oldfred, thank you both for your input and suggestions, much appreciated.

share|improve this answer
add comment

It looks like you ran the rename function of Boot-Repair. That is for systems that only boot the Windows efi file (hardcoded in UEFI).

renamed /EFI/microsoft/boot/shimx64.efi to bootmgfw.efi. bootmgfw.efi to bkpbootmgfw.efi

So you would still boot Windows from UEFI menu and it will really boot to grub menu. From grub menu you can boot the backed up Windows file.

If you can boot ubuntu directly in UEFI menu you can undo the rename. To undo & to rename files to their original names, you just need to tick the "Restore EFI backups" option of Boot-Repair.

Do you have secure boot on? It only shows secure boot systems with secure boot on.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.