Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I wiped my entire system through the BIOS by restoring to default and now I want to install ubuntu on my laptop (64-bit Asus Zenbook). There's nothing on it, when I turn it on it automatically goes to the BIOS.

This is a completely new laptop and I actually installed ubuntu 12.04 on it before the reformatting, with the same bootable usb I'm using now. The laptop has a 24 GB SSD and a 500 GB HDD, it came with Win8 on the SSD and I didn't want Win on it, that's why I reformatted it. I can see both drives in the BIOS. When I installed 12.04 the first time, I placed it on the HDD. I'd like to put 12.04 on the SSD. The SATA is set to ACHI, so that should be ok.

I have a bootable USB with 12.04 and the laptop correctly shows the start menu where I can choose between trying ubuntu, installing ubuntu or checking the desk. No matter what option I pick, the screen just goes to black and nothing happens (I've waited more than 10 minutes).
What I can see is this
UEFI installer pic

Any ideas? Do I need to install something before I can install ubuntu?

Thank you.

Info about the laptop:
ASUS ZENBOOK UX32A R3013H
Intel® Core™ i5 3317U Processor, Integrated Intel® HD Graphics 4000, 500GB HDD With 24 GB SSD Specifications

share|improve this question

marked as duplicate by Eliah Kagan, Jorge Castro, Eric Carvalho, Alvin Row, Kevin Bowen Aug 14 '13 at 7:06

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
@geezanansa Sorry about the mess, I've added more info now. If there's still missing something, please let me know. –  LTP Aug 13 '13 at 14:28
    
I tried enabling the CSM setting and it still doesn't work. When I do it and hit "Save" and then reboot, it's disabled again. I put in the USB, enabled the CSM and hit F10 (saves and reboots), still not working. I'll check out the link, thanks. –  LTP Aug 13 '13 at 14:56
2  
Oh, I got it to work now! I disabled Secure boot as described in the link you sent and yay, now it works! Thank you for your help and patience, I would upvote you if I could. –  LTP Aug 13 '13 at 15:02
    
For more relevant info regarding using Ubuntu on this machine see ubuntuforums.org/… –  geezanansa Aug 14 '13 at 12:53

2 Answers 2

The picture you have shared indicates Ubuntu UEFI installer running but due to your particular hardware it can not run. The picture actually only confirms DVD/USB booted using UEFI and there will be some means in firmware settings to ensure drives are booted in order to make UEFI installer run - possibly. See UEFI - Community Ubuntu Documentation for some info.

The SATA set to AHCI is good. What you need to check is first disable SECURE BOOT in firmware settings. If that does not get Ubuntu installer running. Try disabling anything mentioning UEFI in firmware settings.

Or if you can not find UEFI settings; Does your machine have CSM setting?; if so switch it on - this will disable the UEFI booting of installer and then allow a legacy/bios install of Ubuntu.

Manual found here and looking at page 64 shows instruction for booting other OS (not Windows) The note at top of page demands RAID0 must be set at default settings.

share|improve this answer
1  
This is a completely new laptop and I actually installed ubuntu 12.04 on it before the reformatting, with the same bootable usb I'm using now. The laptop has a 24 GB SDD and a 500 GB HDD, it came with Win8 on the SDD and I didn't want Win on it, that's why I reformatted it. I can see both drives in the BIOS. When I installed 12.04 the first time, I placed it on the HDD. I'd like to put 12.04 on the SDD, but yeah, first I need to get it to work. The SATA is set to ACHI, so that should be ok. –  LTP Aug 13 '13 at 13:29
1  
Thanks again, I can only find "Fast Boot" which I've disabled (still no dice) and no mention of UEFI anywhere. It looks like this: nekkidblogger.com/pics/ubuntu-frozen-menu.jpg so no mentioning of the memory test. All the options lead to a black screen. I'm going to test the hdd status now, but it's only been a week since I installed 12.04 with no problems, and the computer is less than 2 weeks old, so I hope that's not the problem –  LTP Aug 13 '13 at 14:19

This might not be an full answer, but a simple tip that might solve the problem.

Try installing a 32-bit version of Ubuntu 13.04 (as it is faster than 12.04) on a DIFFERENT USB Drive. Maybe it will help.

I have installed Ubuntu through many different pen drives. The thing I noticed is that, each had its own different speed. For example, I tried installing Ubuntu 13.04 32-bit from a Sony 4GB USB Drive and a 2GB Kingston Pen Drive. I found that the 2GB one was faster. Not only that, I also tried the comparison between different flavours (x86, x86_64).

share|improve this answer
1  
Thanks, I tried it and it didn't work, unfortunately. –  LTP Aug 13 '13 at 13:31

Not the answer you're looking for? Browse other questions tagged or ask your own question.