Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I know this has been asked quite a few times already, however, I still don't have it working.

I'm using Qbittorrent as my torrent program, and I want to be able to open magnet links in Firefox.

I already chose qbittorrent as my magnet application handler (in firefox preferences - applications. I chose qbittorrent, located in /usr/bin/).

It's not working. Whenever I click on "download torrent", nothing happens.

Any ideas?

Now that I took another look on my firefox preferences, I see that "magnet" has still "always ask" as its value. I tried to change it, but I can't. It always goes back to "Always ask".

share|improve this question
    
Just tried the most upvoted answer in the link you gave me, Braim (askubuntu.com/questions/311537/…) and still, nothing changed. –  Crex Aug 13 '13 at 12:28
    
I tried the first part of your solution and still, no changes. this is getting frustrating. –  Crex Aug 13 '13 at 12:36
    
I'd like to add that it works flawlessly with Chromium. Oh, and when i go to "applications", in firefox, it still has "always ask" has the magnet value. –  Crex Aug 13 '13 at 12:39
    
Not a dupe, the problem was in Firefox, not xdg as the duplicated suggest. –  Braiam Oct 1 '13 at 13:36

1 Answer 1

up vote 2 down vote accepted

If you already exhausted all solutions, you may want to take a look to your about:config page, in Firefox. It should have a boolean called network.protocol-handler.expose.magnet and it's value should be false.

If you don't have it:

  • Right click on an empty area of the about:config page
  • Select New > Boolean.
  • Name should be network.protocol-handler.expose.magnet and the value false.
  • Restart firefox and try again.
share|improve this answer
    
I didn't have that parameter, and so I added, as you told me to. Still, nothing changed. Wth is wrong with my *"#(/ configuration? –  Crex Aug 13 '13 at 13:06
    
Alright Braiam. I have it solved. What did I do? Well, what fixed it was a firefox re-install (removed firefox and installed firefox). However, I'll accept your answer. Thank you –  Crex Aug 13 '13 at 13:11
    
Oh, actually. After re-installation, I went to applications (in Firefox preferences) and added qbittorrent has the magnet value. Whenever I did that pre-reinstalletion, it would always change back to "Always ask". Not this time. And it worked. –  Crex Aug 13 '13 at 13:13
    
For those of you still struggling, you may also need to temporarily change network.protocol-handler.expose-all to false. –  György Andrasek Nov 28 '13 at 11:12

protected by Community Mar 11 at 21:58

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.