Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to transfer a file from Site5 to Godaddy web hosting account. The godaddy webhosting account is the one that comes free with the domain, so no ssh acccess.

sudo scp -v @:/home//wordpress.tar -o 'StrictHostKeyChecking no' @www.domain.com:/home/content/m/c/o//wordpress.tar

The destination is a godaddy free hosting acccount, and the username on it is the ftp user name.

I am getting the following error when I try to enter the password of the godaddy ftpuser

debug1: Authentications that can continue: publickey,password,keyboard-interactive
debug1: Next authentication method: publickey
debug1: Trying private key: /root/.ssh/id_rsa
debug1: Trying private key: /root/.ssh/id_dsa
debug1: Trying private key: /root/.ssh/id_ecdsa
debug1: Next authentication method: keyboard-interactive
debug1: Authentications that can continue: publickey,password,keyboard-interactive
debug1: Next authentication method: password
mconsys@www.mcruiseon.com's password: 
debug1: Authentications that can continue: publickey,password,keyboard-interactive
Permission denied, please try again.
mconsys@www.mcruiseon.com's password: 
debug1: Authentications that can continue: publickey,password,keyboard-interactive
Permission denied, please try again.
mconsys@www.mcruiseon.com's password: 
debug1: Authentications that can continue: publickey,password,keyboard-interactive
debug1: No more authentication methods to try.
Permission denied (publickey,password,keyboard-interactive).
lost connection

What am I doing wrong here ?

Edit (some more to help debug the issue)

When I try using FTPZilla, with FTP port it connects to the server fine. As soon as I put port 22, it accepts the RSA thingy and gives a error.

Response:   fzSftp started
Command:    open "mconsys@www.mcruiseon.com" 22
Command:    Trust new Hostkey: Once
Command:    Pass: ************
Error:  Authentication failed.
Error:  Critical error
Error:  Could not connect to server

Edit 2

Ftp from the ssh enabled site5 server, gives the following error

ftp  mconsys@www.mcruiseon.com
ftp: mconsys@www.mcruiseon.com: unknown host
share|improve this question
    
scp uses sftp which is (for all intents and purposes) ssh. If you don't have ssh access, this probably won't work and you'll need FTP (or other) –  Oli Aug 13 '13 at 9:46
    
Cant I get scp to force a ftp login ? Sorry, silly question. –  Siddharth Aug 13 '13 at 9:47
    
OR cant I ftp into that server ? –  Siddharth Aug 13 '13 at 9:48
    
The FTP error is something specific to you - there is an FTP server there when I run telnet www.mcruiseon.com 21 –  Oli Aug 13 '13 at 9:55
    
Actually, do you have some sort of DNS override in /etc/hosts? It looks like you might be sending requests for www.mcruiseon.com to localhost (which would explain the authentication and lack of ftp servers) –  Oli Aug 13 '13 at 9:56

1 Answer 1

up vote 2 down vote accepted

sftp and ftp are completely different protocols so, if as you say you don't have ssh/sftp access at one end, I don't think there's any value in persuing a scp option.

I would personally ssh into the end you do have access at and then use whatever protocol you have access to to push (or pull) the files across. In you were using ftp:

user@home$ ssh user@server.com
user@server$ ftp server2.com
> # login here
> cd /the/right/path
> mget * 
> mput *
> bye

You don't want both mget or mput, just pick the one that suits the direction you're pushing or pulling files.

share|improve this answer
    
Thanks, your answer gave me the hint. I was adding ftp user@server, while I should have just ftp server. Thanks. –  Siddharth Aug 13 '13 at 10:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.