Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So i have always been a windows user and this was my first time installing a linux based os to my computer. After watching a tutorial on youtbe and reading the guide on the ubuntu website the installation seemed straight forward and for the most part it was, After succesfully installing Ubuntu alongside Windows 8 ubuntu promped me to restart my computer so i did, after it restarted instead of giving me a screen where i can choose wich OS i can boot it just went straight to Windows 8, i have no idea how to run the Ubuntu i installed because every time i restart it goes straight to windows. I am kind of sad because i allocated 100GB of HDD space to ubuntu and it would be a shame that i wont be able to get it back. Can anyone help me with this. I am 100% new to linux. If needed these are my PC specs Intel i7-3632qm Quad Core 64bit 8GB RAM DDR3 1TB HDD HP Envy m4 laptop

share|improve this question
    
Did you choose ubuntu in the menu? –  M.Tarun Aug 13 '13 at 6:22
1  
There is no option to choose ubuntu, it only boots Windows 8 when it turns on. –  Cesar Mendoza Aug 13 '13 at 6:29
    
Did you make the partitions yourself? –  M.Tarun Aug 13 '13 at 6:32
1  
If you mean that fi i chose the option "Run Ubuntu alongside Windows 8" or the option "Something Else" i did i chose the run ubuntu alongside windows 8 option. oh and i gave ubuntu 100gb –  Cesar Mendoza Aug 13 '13 at 6:39
    
Please tell that when you boot from the Ubuntu Live DVD does it display the menu with black background (UEFI) or purple background (BIOS)... This link should help you decide- help.ubuntu.com/community/UEFI –  Aaditya Bagga Aug 14 '13 at 5:40

2 Answers 2

*Note-*If anyone can help the gentlemen directly most welcome, i did not find a simple clearcut solution on the net so i have complied this list.

List of compiled links-

UEFI and Windows 8

https://help.ubuntu.com/community/UEFI

Installing Ubuntu on a Pre-Installed Windows 8 (64-bit) System (UEFI Supported)

How to turn Secure Boot Off in Windows 8

http://www.maketecheasier.com/disable-secure-boot-in-windows-8/2013/02/25

http://tutorialforlinux.com/2013/01/windows8-howtodisablesecureboot-bootfromcddvdinstallationmedia/

Threads about installing Ubuntu Dual Boot with Windows 8

http://ubuntuforums.org/showthread.php?t=2152988

http://ubuntuforums.org/showthread.php?t=2123975&page=2&s=619cd6fc5d64a052c769cd8f076fc68d

share|improve this answer
    
Thanks this is exactly what i needed! Thank You! –  Cesar Mendoza Aug 14 '13 at 17:22
    
You are most welcome :) If it solved your problem, please mark this answer as solved. –  Aaditya Bagga Aug 14 '13 at 18:02
1  
And it would be helpful for other users if you could mention what solved your problem, was it disabling the Secure Boot or something else? Thank You. –  Aaditya Bagga Aug 14 '13 at 20:30

It seems that the Ubuntu bootloader (grub) has not been installed correctly. So you could boot from the dvd from which you installed ubuntu , and then follow this guide- https://help.ubuntu.com/community/Boot-Repair

share|improve this answer
    
Thanks Mate! i decided to remove it all and start fresh, which version do you recommend for Windows 8 Ubuntu 12.04 or 13.04? –  Cesar Mendoza Aug 13 '13 at 7:21
    
You are welcome :) and 13.04 is better (13.04 is the latest version released on april, 2013 : hence 13.04. and is better suited for installation alongside windows 8) –  Aaditya Bagga Aug 13 '13 at 7:24
    
Hello i re-installed ubuntu and saw that grub or the choose OS screen wasnt working again, the computer just went straight to Windows 8, so i tried to re-install grub from the live CD meathod, i followed all the steps and it set boot repair succesfull and that i can now restart my computer. When i re-started my computer i expected to see grub but instead it went straight to Windows 8 again, i went to the live CD again and tried the Sudo fdisk meathod on the terminal to re-install grub but when i want to pick my root partition for linux it doesn't appear on the list... –  Cesar Mendoza Aug 13 '13 at 20:06
    
Ok sir... it could be because you have a Winodws 8 in UEFI mode (its a new technology) and a HP laptop which are known to be problematic with UEFI. I will post a step by step guide for you very shortly. –  Aaditya Bagga Aug 14 '13 at 4:10
    
Sir I think that you need to turn the Secure Boot option off- Here is a detailed guide on it - maketecheasier.com/disable-secure-boot-in-windows-8/2013/02/25 and 1 more tutorialforlinux.com/2013/01/… –  Aaditya Bagga Aug 14 '13 at 5:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.