Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I did look around (including other websites) and couldn't find any solutions to my issue installing ubuntu 12.04 on my macbook pro (mid 2010).

Basically I had my macbook and decided it was getting slow and old so I upgraded the RAM and upgraded my 250 GB HD to a 1 TB SSHD (seagate). Prior to the update I had Windows 7 and Ubuntu installed, and I was triple booting with rEFIt. I previously installed Ubuntu using a live USB.

So I installed rEFIt and Windows 7 again without problems. First in installing Ubuntu 12.04 I downloaded the .iso and using the instructions on Ubuntu's website I used terminal and created the bootable USB. My first problem was after the process the USB was no longer recognized by my macbook. I tried other methods (using disc utility) I read about with no luck. Then I used an app which does it for me, which worked. But when the installation process started after booting the usb, it would always hang at the 'booting the kernel' step. I researched more and read somewhere about trying 64 bit. I tried that but during the startup it brings me to a full screen terminal type of prompt.

Which is where I currently stuck. I'm pretty confused because the first time I installed Ubuntu I ran into almost no problems and it was a pretty quick and painless process. Any help would be much appreciated!

Heres all my computer specs incase it'll help: Processor 2.4 GHz Intel Core 2 Duo Memory 8 GB 1067 MHz DDR3 (crucial) Hard Drive 1 TB SSHD (seagate)

Running OSX Lion (i was also using Lion the first time)


EDIT 8.14.13

So I used the instructions here and got a little further. I followed what they said, using the correct version of Ubuntu for my 2010 Macbook. This time I got past the boot screen and Ubuntu's splash screen. Then a message pops up saying it could not configure the graphics. It says I could do it manually or boot it into low graphics mode. When I attempt to set the graphics it wont let me. I just hit ok and the message keeps popping up. When I choose low graphics thats just another terminal-like screen.

Any help is greatly appreciated!

share|improve this question
    
here is the solution .click here to go to the link I think this will help you. –  Thusitha Sumanadasa Aug 13 '13 at 4:41
    
And this is from official documentationof that . –  Thusitha Sumanadasa Aug 13 '13 at 4:46
    
Still gets stuck on the 'booting the kernel' stage. I tried using the solution they used and installing 12.10 (for the 7,1 macbook) –  Phil B Aug 14 '13 at 4:54
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.