Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

In an attempt to install Blackberry application (Barry) following guide listed at: installing or setting up barry in ubuntu 12.04

I got the error:

Could not save the file /etc/apt/sources.list.d/barry.list. You do not have the permissions necessary to save the file. Please check that you typed the location correctly and try again.

Right clicked on folder sources.list and under permissions I found that Root have create and access permissions while group and others have access only permissions then at the bottom "you are not the owner, so you can not change these permissions".

Am new to Ubuntu (Wubi)and not sure how to change these permissions am the only user and my password is/was root installation password.

share|improve this question
    
Could you please tell the previous command that triggered the error? –  Braiam Aug 12 '13 at 17:23
add comment

marked as duplicate by bcbc, Eric Carvalho, Alvin Row, Kevin Bowen, chronitis Aug 13 '13 at 8:40

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer

Ok..So so to edit the file use

sudo gedit /etc/apt/sources.list

When you type the given command, it will ask for password. Give it your password (which is the same as the root password and enter)

Then when you try to save it will save.

After that just follow the guide whose link you have provided.

For your help-

the sudo command (along with other commands) is used in Linux to perform all the tasks that the root (super user) can.

sudo stands for super user do.

gedit is a text editor.

so sudo gedit /etc/apt/sources.list

opens the file /etc/apt/sources.list in text editor gedit with root privileges

share|improve this answer
    
sudo: gedit /etc/apt/sources.list command not found, although gedit is installed, Thanks –  user176105 Aug 13 '13 at 13:27
    
please follow the link given at the top of the page askubuntu.com/questions/92379/… and see if it helps you, otherwise post here. –  Aaditya Bagga Aug 13 '13 at 13:35
    
It worked after a repository update. –  user176105 Aug 17 '13 at 11:20
    
ok...if my answer helped you, please mark it as solved :) –  Aaditya Bagga Aug 17 '13 at 14:40
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.