Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to install the drivers for my Radeon HD 4250 graphics card on my Lubuntu 13.04 station.

I want to run multiple monitors (1 VGA 1 HDMI) but I am having overscan issues on the HDMI monitor.

I attempted to install from the drivers list on the AMD website but when I attempt to install the drive it says that I need to install one or more required tools before being able to install the driver.

  • I have tried to run with --force and I just end up having even crappier display.
  • I attempted to install via the xorg-edgers repo but I still can't find a AMD CCC driver in the additional drivers tab
share|improve this question
1  
have you checked this - What is the correct way to install ATI Catalyst Video Drivers (fglrx)? –  Web-E Aug 12 '13 at 11:59

1 Answer 1

AMD dropped support for the Radeon HD 4xxx cards in May. You'll have to install the Catalyst Legacy driver. However, the Catalyst Legacy driver only supports kernel version 3.4 and xorg version 1.12.4, and Lubuntu 13.04 ships with kernel version 3.8 and xorg version 1.13

To install the Catalyst legacy driver, you'll have to downgrade xorg to version 1.12 and patch the driver.

Luckily, this can be done in a few simple steps, by adding a ppa that contains a patched version of the Catalyst Legacy driver.

To do this, open a terminal window (press ALT+F2 and type xterm or your favorite terminal emulator)

Enter the following commands:

sudo add-apt-repository ppa:makson96/fglrx
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install fglrx-legacy

This way, you'll add Tomasz Makarewicz's ppa that contains the patched driver. It will also automatically downgrade your xorg version to 1.12.

Once the install finishes, reboot your machine and you should be using the Catalyst Legacy driver. You can then start the AMD Catalyst Control Center by opening your terminal emulator and running sudo amdcccle

share|improve this answer
1  
this worked great, thanks! –  user183449 Aug 12 '13 at 13:12
    
Could you please mark my answer as "accepted" then? –  muis24 Aug 12 '13 at 20:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.