Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm setting up a brand new HP ProBook 6570b with an integrated ATI 7500M video card.

After starting the Ubuntu 12.04 64 bit Live installer the desktop comes up well in a few seconds and all seems fine. Installation is quick and smooth.

After the first reboot the first bad surprise.

Screen is almost deep purple, no login is possible, even Ctrl-Alt-F1 is not working at all. Rebooting and neither the Grub boot menu is visibile! Aaargh....

So I restarted from USB with the installer to do some rescue, and after commenting out these damned 2 lines in /etc/default/grub:

#GRUB_HIDDEN_TIMEOUT=0
#GRUB_HIDDEN_TIMEOUT_QUIET=true

and rebooting, now Grub boot menu is ok, but after the reboot the screen is badly split (screenshot here: https://www.dropbox.com/sc/zy02pij9lrzaqmj/YQ0HwyTmHS). Tried to install fglrx driver from the Precise repository but it is using a too old driver which is not aware of this chipset model.

Then tried to use the latest AMD Catalyst driver (version 13.4) using the best guide around (http://wiki.cchtml.com/index.php/Ubuntu_Precise_Installation_Guide) and now I finally got a working Ubuntu 12.04.

I state that I'm working with Linux since almost 20 years and that I'm an Ubuntu big fan, it's a pity IMVHO that if a newbie will try Ubuntu on this laptop will have a really negative experience. I've the following questions:

  1. Why the Live is working so well with the open source driver, but at reboot it will not work at all ?
  2. the Grub hidden menu gave me lot of hassle with several systems, why keep it enabled by default ?
  3. why the fglrx driver is so old in 12.04, being an LTS release ?

Hoping to be helpful to someone who will use Ubuntu 12.04 on this laptop model.

Quick update: using dual monitor configuration with a Virtual of 3200x900 will not work since X will SegFault. The workaround that worked for me is the following: 1. Use the xorg-edgers PPA to get updated Xorg for 12.04 2. Use the raring 3.8 kernel: $ sudo apt-get linux-generic-lts-raring

share|improve this question
add comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.