Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The "Language Support" icon from the System settings has disappeared:

No language support icon in System Settings

(Also I can't find it from Dash)

The last thing I've done was changing the keyboard input method system to "ibus".

I tried to execute gnome-control-center directly in the command line, expecting to see errors in the output, but there is no console output.

Where can I start looking for the cause? Can I call the "Language Support" option directly from command line?

share|improve this question
    
Reinstalling gnome-control-center usually helps. –  Danatela Aug 12 '13 at 3:43
4  
Try running the command gnome-language-selector. If that doesn't work, make sure you have the package language-selector-gnome installed. –  Alvin Row Aug 12 '13 at 4:01
    
@DoR I had to install that package, after that the "Language Support" icon appears again! I think the cause was the im-switch package. Can you post your comment as an answer so I can accept it? Thanks –  dusan Aug 13 '13 at 0:34

2 Answers 2

up vote 3 down vote accepted

The Language Support utility is provided by the language-selector-gnomeInstall language-selector-gnome package.

Once you install that package, you'll see the language option in the System Settings again.

share|improve this answer

I get same problem in Ubuntu 13.10 too. "Language support" disappeared right after installing ibus framework, I didn't even set input method system as "ibus". I tried "sudo apt-get install language-selector" and it's back again. But I've still no idea why it just disappears.

share|improve this answer
1  
In my case installing the im-switch package removed the language-selector-gnome package. Maybe they can't coexist together. –  dusan Nov 6 '13 at 18:17
    
Install im-swtich was the problem for me. So this fix this problem. sudo apt-get purge im-switch && sudo apt-get install language-selector-gnome then login and logout and the language icon should reappear in the system settings. –  Larry Battle Nov 26 '13 at 3:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.