Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using Ubuntu 12.04.

I've been trying to figure out what is causing my Xorg and Compiz to frequently come close to maxing out my CPU usage for weeks now. Essentially, during normal use, both processes will fluctuate between using next to no CPU to all of my CPU.

I did a little research and it might be a memory leak, but I'm not entirely sure. Does anyone know what could be causing this issue, and how I could go about fixing it?


I'm using an ATI Mobility Radeon 5400.

$ lspci | grep VGA
01:05.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI RS880M [Mobility Radeon HD 4200 Series]
02:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Manhattan [Mobility Radeon HD 5400 Series]


$ glxinfo | grep render
direct rendering: Yes
OpenGL renderer string: Gallium 0.4 on AMD RS880
    GL_NV_conditional_render, GL_AMD_conservative_depth,
share|improve this question
2  
What Graphic Card are you using? Please add the output of lspci | grep VGA, glxinfo | grep render and the content of your /var/log/Xorg.0.log. –  Braiam Aug 12 '13 at 1:49
    
Also, unity support test is useful. I think it will show that software rendering it's active. –  Danatela Aug 12 '13 at 4:26

1 Answer 1

I used "Compiz Config Settings Manager" to resolve the same issue. Though it wasn't using nearly as much of my CPU, just enough to annoy me from time to time.

sudo apt-get install compizconfig-settings-manager

After installation, press the Super/Windows key, and begin to type "Compiz", after which you can select the tool. (There is a warning upon opening the application, stating to be wary of changes made.) Click "Ok" and click on "OpenGL" (The actual words)

Uncheck "Sync to VBlank", and depending on your system, change the "Texture Filter" accordingly. (I personally have mine set to "Fast" and have not experienced any issues.)

Afterwards I exited the application, and restarted my computer without any further problems.

share|improve this answer
    
some information on "Sync to VBlank" ubuntuforums.org/showthread.php?t=1537858 –  Hongbo Zhu May 27 at 9:50
    
If you have nvidia drivers, you might want to try turning off "Sync to Vblank" in the nvidia settings as well. –  Gauthier Oct 13 at 8:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.