Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I know this is a duplicate question but I have tried everything that I've seen in the answers. No matter what I try it won't do anything. I have unity enabled and still nothing. Is there something I'm not doing. What fixed it for you guys? I tried Press Ctrl+Alt+F1 and log in.

Install the jibby you'll need to configure the settings by running this:

sudo apt-get install compizconfig-settings-manager

Then run it by doing this:

export DISPLAY=:0
ccsm

The first part tells the terminal which display you want it to load on (otherwise it won't have a clue).

Press Ctrl+Alt+F7 (or Ctrl+Alt+F8 sometimes) to get back to the graphical display where there should be a CompizConfig Settings Manager screen sitting there.

Find the Unity plugin. Enable it.

Everything should spring into life but if it doesn't, you might have to restart. You can do that by going back to TTY1 and running sudo reboot. But nothing worked. I also tried dconf reset -f /org/compiz/ 

unity --reset-icons &disown but nothing happened.I tried

Press Ctrl+Alt+F2.

Log in.

Run sudo shutdown -r now in a terminal.

At the login screen after your system restarts, choose Unity 2D (for now) by right-clicking the sprocket icon.

Wait for a fix for Unity 3D/Ubuntu 11.10 (e.g. a week).

Update your system to get the fix; in a terminal type sudo apt-get update && sudo apt-get upgrade.

UPDATE: I was able to resolve this by using ccsm, from Unity 2D login.

(This is adapted from this Ubuntu Forums post.)

At the login screen, select Unity 2D and login.

Install ccsm (CompizConfig Settings Manager) by running in a terminal: sudo apt-get install compizconfig-settings-manager compiz-fusion-plugins-extra.

Start ccsm, and select the category Desktop. Enable the Ubuntu Unity Plugin; if asked to resolve conflicts, select the MIDDLE button for all conflicts. Close ccsm when done.

Restart, select Unity (3D) and login.

but found no Unity 2d to select. I also tried rm -rf .compiz-1 and rm -rf ~/.config/compiz-1/compizconfig/* but nothing happened. I also tried ctrl+alt+f1 (ok, blank screen) type your login, hit Enter, then password (all in blank screen) type this now:

sudo startx -- :1

will have to type password again and Enter this will open a X session at ctrl+alt+f8 (will jump to it automatically) now create a new empty text file called runBash.sh, and type on it:

bash

save it, change its permissions to executable, and run it, you will get a truly relieving terminal that makes you remember why linux is good ! :D

after you finish, remember to ctrl+alt+f1, hit ctrl+c (will end the new X session), type exit, Enter, will end the terminal (blank screen) session. if you think you missed typing exit, just hit ctrl+c and type again, dont do it too fast...

but couldn't get it to run as a executable file.

I also tried: Solution found : Delete .Xauthority in my home (or rename it) but I didn't find that file.

share|improve this question
    
Please, edit your question and add what you have already tried, what didn't work, if there was an error during any of the procedure, the version of Ubuntu/Unity, the contents of ~/.xsession-errors and /var/log/Xorg.0.log, any other relevant information. –  Braiam Aug 12 '13 at 1:31
    
How were you looking for .Xauthority?? Most applications including ls hide files prepended with a period. To avoid this, use ls -a, or enable the display of hidden files in nautilus preferences, etc. Also, you can directly use rm .Xauthority. –  Yet Another User Aug 12 '13 at 2:57
    
Huh I deleted it but nothing happened. –  mickey_master18 Aug 12 '13 at 3:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.