Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I use Ubuntu 10.10 on a laptop, with an external monitor, which is used as the primary. Notify-osd alerts show on the connected monitor, as I want.

However, some days ago I removed both gnome panels and installed AWN. All was good, but notify-osd alerts now appears on the laptop. I need, that notify-osd appears on the connected monitor.

How can I move notify-osd alerts on the connected monitor without gnome panels?

share|improve this question
    
Did you set the external monitor as primary? –  Jonathan Apr 12 '11 at 20:01
add comment

3 Answers

gsettings set com.canonical.notify-osd multihead-mode focus-follow

This is the correct way for 12.10. You can test with notify-send

share|improve this answer
    
This will work on 13.04 Unity –  Andy Braham Oct 5 '13 at 19:46
add comment
gconftool-2 -s -t string /apps/notify-osd/multihead_mode focus-follow

Should display notices on the currently active monitor.

share|improve this answer
1  
are there other options besides focus-follow? what if I wanted to pick a specific montior to show notifications on? –  tester Nov 11 '11 at 18:08
    
You can use gconf-editor ( dconf-editor on 11.10 ) to see all available options. –  Yuriy Voziy Jan 13 '12 at 15:29
2  
Setting this value doesn't seem to have any effect in 12.10. I did a quick search in dconf and there doesn't seem to be a notify-osd node. –  Erigami Dec 6 '12 at 19:31
add comment

Hmm interesting, it should show up on Primary screen by default and we can choose the monitor in shell like this DISPLAY=:0 notify-send "hi" and DISPLAY=:1 notify-send "hi"

share|improve this answer
    
As far as I know, the DISPLAY option has nothing to do with multiple monitors. Testing this on Ubuntu 12.04 (with focus-follow set as described above), it doesn't seem to do what you suggest either. –  Joel Cross Feb 21 at 14:57
    
Used to work for me earlier but not using the same setup anymore. –  Ashfame Feb 21 at 15:15
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.