Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I can run it in safe mode and get the root prompt, but if I let it boot normally I just get a black screen. A similar question was asked here:

PC does not restart after last kernel update

but I don't have a Nvidia graphics card. I am able to boot 3.2.0-43 just fine.

I did find this error in the kernel.log after trying to boot 3.2.0-51:

Aug 11 12:03:26 iceman kernel: [2.672181] [drm] MTRR allocation failed.  Graphics performance may suffer.
share|improve this question
add comment

1 Answer

  1. Boot to your root prompt.
  2. # lspci -vvk >> ~/devices.txt
  3. Post the devices.txt file here.
  4. Build your own kernel making sure to use menuconfig for your arch.

Be sure to enable MTRR for your system and possibly your VGA adapter. Look for this option in menuconfig:

Processor type and features  --->
[*] MTRR (Memory Type Range Register) support
 [*]   MTRR cleanup support 
 (1)     MTRR cleanup enable value (0-1)
 (1)     MTRR cleanup spare reg num (0-7)
[*]   x86 PAT support 

If those options are enabled, you need to enable the kernel command line options for your vga device. See Here. Yes, the Distro is different, but the concept is the same.

share|improve this answer
    
Thanks for the the response E Carter Young, but later kernels fixed my issue and I no longer have the setup to test any further. –  gaucho Apr 14 at 17:46
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.