Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I can't compile any program in QtCreator on Lubuntu 13.04. I have this error:

QtCreator needs a compiler set up to build. Configure a compiler in the kit options

First of all, I installed from Synaptic gcc-mingw32 and mingw32 with dependencies, so the list of downloading packages files looked like this:

binutils (version 2.23.2-2ubuntu1) will be installed
binutils-mingw-w64-i686 (version 2.22.90.20120919-0ubuntu1+2) will be installed
binutils-mingw-w64-x86-64 (version 2.22.90.20120919-0ubuntu1+2) will be installed
cpp-4.6 (version 4.6.4-1ubuntu1) will be installed
g++-4.6 (version 4.6.4-1ubuntu1) will be installed
g++-mingw-w64-i686 (version 4.6.3-13ubuntu1+8) will be installed
g++-mingw-w64-x86-64 (version 4.6.3-13ubuntu1+8) will be installed
gcc-4.6 (version 4.6.4-1ubuntu1) will be installed
gcc-4.6-base (version 4.6.4-1ubuntu1) will be installed
gcc-mingw-w64-base (version 4.6.3-13ubuntu1+8) will be installed
gcc-mingw-w64-i686 (version 4.6.3-13ubuntu1+8) will be installed
gcc-mingw-w64-x86-64 (version 4.6.3-13ubuntu1+8) will be installed
gfortran-mingw-w64-i686 (version 4.6.3-13ubuntu1+8) will be installed
gfortran-mingw-w64-x86-64 (version 4.6.3-13ubuntu1+8) will be installed
libc-dev-bin (version 2.17-0ubuntu5) will be installed
libc6-dev (version 2.17-0ubuntu5) will be installed
libstdc++6-4.6-dev (version 4.6.4-1ubuntu1) will be installed
linux-libc-dev (version 3.8.0-27.40) will be installed
manpages-dev (version 3.44-0ubuntu1) will be installed
mingw-w64-i686-dev (version 2.0.3-1) will be installed
mingw-w64-x86-64-dev (version 2.0.3-1) will be installed
mingw32 (version 4.2.1.dfsg-2ubuntu1) will be installed
mingw32-binutils (version 2.20-0.2) will be installed
mingw32-runtime (version 3.15.2-0ubuntu1) will be installed

Then I downloaded newest Qt 5.1.0 for Linux 32-bit from qt-project.org/downloads and I installed it without any problems. In installation options I had checked "gcc".

Then, I created new project. In Kit Selection I had default checked "Desktop Qt 5.1.0 GCC 32bit". I wrote some code, tried to compile it, and I have mentioned error about compiler. I thought QtCreator will detect gcc (or mingw).

In Options window, section "Build & Run", tab Compilers I have nothing. So I added new compiler GCC and set following file:

/home/rafal/Qt5.1.0/5.1.0/gcc/bin/qmake

But I have no idea if is this the right file. I set ABI to: x86, linux, generic, elf, 32 bit, but also I'm not sure about it. Then, in "Kits" tab I added new one, and this one has GCC compiler. I set this kit to default. I go back to the code, I try to compile it once again, and then I have this error:

18:03:16: Running steps for project TestApp...
18:03:16: Configuration unchanged, skipping qmake step.
18:03:16: Could not start process "make" 
Error while building/deploying project TestApp (kit: Desktop Qt 5.1.0 GCC 32bit)
When executing step 'Make'
18:03:16: Elapsed time: 00:00.

I also installed g++, and I get the same.

And I don't know what to do.

Can someone help me, please? What am I doing wrong?

share|improve this question
    
Problem solved. I had to install compilers using $ sudo apt-get install build-essential. –  Jan Kowalski Aug 13 '13 at 11:31

1 Answer 1

The OP solved the problem by installing build-essential. To install it just type the following command.

sudo apt-get install build-essential
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.