Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have this Canon LiDE 200 but simple scan cannot use it properly. With the new sane-backend from rober-ancell's ppa the scanner head at least moves a little, but simple-scan simply fails telling me that the scanning fails in a red banner below the menu bar.

Is there some way to get it to work?

share|improve this question
up vote 7 down vote accepted

I had the same error as the original poster, which led me here.

The 40-libsane.rules file and the sane compatibility list suggested it should "just work", so I tinkered a bit and found that if you change the setting in Simple Scan preferences called Scan Side and set it to Back (rather than the default Front and Back), all is good.

share|improve this answer
Wow, that feels like vodoo :-). I think I'll have to experiment with the gamma options of scanimage until the scans look good. – Martin Ueding Feb 7 '12 at 20:01

First I followed the recommendations:

sudo add-apt-repository ppa:robert-ancell/sane-backends
sudo apt-get update
sudo apt-get install libsane libsane-extras sane-utils

Then I installed xsane and finally my Canoscan Lide 200 started to work.

share|improve this answer
Yes, xsane works, simple-scan not for some reason. – Martin Ueding Aug 22 '11 at 8:18

This last part of the forum entry is what I had to do to get my scanner working

If scanning doesn't work as a regular user, continue with step 3.

3) To allow us to scan as a regular user, we need to modify the USB permissions for the scanner, so follow step 5 from Quote: Originally Posted by dli8ilb
Now everything is installed, but you still won't be able to scan (except as root) until you set up some permissions.

5) You need to edit a file, but you need to be root to edit it, so:

gksu gedit /lib/udev/rules.d/40-libsane.rules

and add the following 2 lines:

# Canon CanoScan Lide 200
ATTRS{idVendor}=="04a9", ATTRS{idProduct}=="1905", ENV{libsane_matched}="yes"

save the file, exit gedit, exit terminal, reboot, and...

My question about this is when a scanner driver is installed why is this file not automatically updated?

share|improve this answer
That file already contains these these lines on my computer. Any other ideas? – Martin Ueding Apr 21 '11 at 19:14

Just had some trouble getting the LiDE 200 working in Simple Scan running Precise.

All I did was change Scan Side to "Back" in Simple Scan Preferences, add myself to the saned group, log out/in and voilà!

Hope this helps.

share|improve this answer

I got exactly the same message on Natty. I installed the PPA: nothing. Running as root: nothing. Then I thought about using xsane so I did a: sudo aptitude install xsane

Then used simple-scan and it worked :s Hope this also helps for you!

share|improve this answer
This sounds strange, but I will give it a try. – Martin Ueding Apr 29 '11 at 16:44
No, it does not work :-/ – Martin Ueding Apr 30 '11 at 12:45
xsane itself seems to work, but simple-scan still fails. – Martin Ueding Apr 30 '11 at 12:58

See this response on the Ubuntu forums. I did something similar for my LiDE 100

share|improve this answer
Please also include the solution. If the forum goes down for maintenance or for good due to an alien invasion, your answer becomes useless. ;-) On a side note: Robert Ancell is a Canonical employee - just to raise confidence that this PPA is legit. – htorque Apr 3 '11 at 8:24
It does recognize the scanner now, and when I clicked “scan”, I heard some noise, but then it failed: ** (simple-scan:6137): WARNING **: Unable to start device: Error during device I/O – Martin Ueding Apr 3 '11 at 13:10
@queueoverflow: Is the scanner unlocked (should have a switch somewhere)? – htorque Apr 4 '11 at 0:52
@htorque: It is unlocked, I used it with Mac OS X just on the same day, the scanner itself seems to work fine. – Martin Ueding Apr 4 '11 at 11:25
The thing is, that it fails consistently on the first scan, but works on every consecutive scan. I wrote a little script that just runs it again if it fails. – Martin Ueding Nov 9 '12 at 20:28

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.