Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running Ubuntu 12.04 and tried to upgrade the kernel from 3.2 to 3.5: Following a suggestion found here, I ran

sudo apt-get install linux-image-generic-lts-quantal

I had a little trouble with it, but after reboot I have

uname -r 

3.5.0-37-generic

However, attempting to install the new X stack results in an error:

sudo apt-get install xserver-xorg-lts-quantal

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:

 gvfs-daemons : Depends: x11-utils

E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

Any suggestions? I tried "sudo apt-get install gvfs-daemons" and "sudo apt-get install x11-utils", but both were up to date.

share|improve this question
    
Can you post the output of dpkg --get-selections | grep hold? –  Braiam Aug 11 '13 at 1:39
    
Duplicate of askubuntu.com/questions/257617/… –  ubfan1 Aug 11 '13 at 2:59
    
Braiam: I ran dpkg as you indicated, but it returned nothing. –  RadarDude Aug 11 '13 at 23:35
    
ubfan1: That link is where I found the instructions to do what I tried to do. It worked well on another computer, but not on this one (yet). –  RadarDude Aug 11 '13 at 23:36

1 Answer 1

For what it's worth, the below is the list of "quantal" packages (mostly X and kernel) on my 12.04.2 system (fresh install), kernel 3.5.0-37. Probably most of the X packages are not needed...

$ dpkg -l |fgrep quantal |sort ii libgl1-mesa-dri-lts-quantal
9.0.3-0ubuntu0.4~precise1 free implementation of the OpenGL API -- DRI modules ii libgl1-mesa-dri-lts-quantal:i386 9.0.3-0ubuntu0.4~precise1 free implementation of the OpenGL API -- DRI modules ii libgl1-mesa-glx-lts-quantal
9.0.3-0ubuntu0.4~precise1 free implementation of the OpenGL API -- GLX runtime ii libgl1-mesa-glx-lts-quantal:i386 9.0.3-0ubuntu0.4~precise1 free implementation of the OpenGL API -- GLX runtime ii libglapi-mesa-lts-quantal
9.0.3-0ubuntu0.4~precise1 free implementation of the GL API -- shared library ii libglapi-mesa-lts-quantal:i386
9.0.3-0ubuntu0.4~precise1 free implementation of the GL API -- shared library ii libxatracker1-lts-quantal
9.0.3-0ubuntu0.4~precise1 X acceleration library -- runtime ii linux-generic-lts-quantal
3.5.0.37.43 Generic Linux kernel image and headers ii linux-headers-generic-lts-quantal
3.5.0.37.43 Generic Linux kernel headers ii linux-image-generic-lts-quantal 3.5.0.37.43
Generic Linux kernel image ii x11-xserver-utils-lts-quantal
7.7~3ubuntu1~precise1 X server utilities ii xserver-common-lts-quantal
2:1.13.0-0ubuntu6.1~precise3 common files used by various X servers ii xserver-xorg-core-lts-quantal
2:1.13.0-0ubuntu6.1~precise3 Xorg X server - core server ii xserver-xorg-input-all-lts-quantal
1:7.7+1ubuntu4~precise1 X.Org X server -- input driver metapackage ii xserver-xorg-input-evdev-lts-quantal
1:2.7.3-0ubuntu2~precise1 X.Org X server -- evdev input driver ii xserver-xorg-input-mouse-lts-quantal
1:1.7.2-2build1~precise1 X.Org X server -- mouse input driver ii xserver-xorg-input-synaptics-lts-quantal
1.6.2-1ubuntu5~precise1 Synaptics TouchPad driver for X.Org server ii xserver-xorg-input-vmmouse-lts-quantal
1:12.9.0-0ubuntu3~precise1 X.Org X server -- VMMouse input driver to use with VMWare ii xserver-xorg-input-wacom-lts-quantal
1:0.17.0-0ubuntu2~precise1 X.Org X server -- Wacom input driver ii xserver-xorg-lts-quantal
1:7.7+1ubuntu4~precise1 X.Org X server ii xserver-xorg-video-all-lts-quantal 1:7.7+1ubuntu4~precise1
X.Org X server -- output driver metapackage ii xserver-xorg-video-ati-lts-quantal
1:6.99.99~git20120913.8637f772-0ubuntu1~precise2 X.Org X server -- AMD/ATI display driver wrapper ii xserver-xorg-video-cirrus-lts-quantal 1:1.5.1-0ubuntu2~precise1 X.Org X server -- Cirrus display driver ii xserver-xorg-video-fbdev-lts-quantal 1:0.4.3-0ubuntu1~precise1 X.Org X server -- fbdev display driver ii xserver-xorg-video-intel-lts-quantal
2:2.20.9-0ubuntu2.2~precise1 X.Org X server -- Intel i8xx, i9xx display driver ii xserver-xorg-video-mach64-lts-quantal 6.9.3-0ubuntu1~precise2
X.Org X server -- ATI Mach64 display driver ii xserver-xorg-video-mga-lts-quantal 1:1.6.2-0ubuntu1~precise2 X.Org X server -- MGA display driver ii xserver-xorg-video-modesetting-lts-quantal 0.5.0-0ubuntu1~precise2
X.Org X server -- Generic modesetting driver ii xserver-xorg-video-neomagic-lts-quantal 1:1.2.7-0ubuntu1~precise1 X.Org X server -- Neomagic display driver ii xserver-xorg-video-nouveau-lts-quantal 1:1.0.2-0ubuntu3~precise2 X.Org X server -- Nouveau display driver ii xserver-xorg-video-openchrome-lts-quantal 1:0.3.1-0ubuntu1~precise3 X.Org X server -- VIA display driver ii xserver-xorg-video-r128-lts-quantal 6.9.1-0ubuntu1~precise2
X.Org X server -- ATI r128 display driver ii xserver-xorg-video-radeon-lts-quantal
1:6.99.99~git20120913.8637f772-0ubuntu1~precise2 X.Org X server -- AMD/ATI Radeon display driver ii xserver-xorg-video-s3-lts-quantal
1:0.6.5-0ubuntu1~precise1 X.Org X server -- legacy S3 display driver ii xserver-xorg-video-savage-lts-quantal
1:2.3.6-0ubuntu1~precise1 X.Org X server -- Savage display driver ii xserver-xorg-video-siliconmotion-lts-quantal 1:1.7.7-0ubuntu1~precise1 X.Org X server -- SiliconMotion display driver ii xserver-xorg-video-sis-lts-quantal
1:0.10.7-0ubuntu1~precise2 X.Org X server -- SiS display driver ii xserver-xorg-video-sisusb-lts-quantal
1:0.9.6-0ubuntu1~precise1 X.Org X server -- SiS USB display driver ii xserver-xorg-video-tdfx-lts-quantal
1:1.4.5-0ubuntu1~precise2 X.Org X server -- tdfx display driver ii xserver-xorg-video-trident-lts-quantal
1:1.3.6-0ubuntu2~precise1 X.Org X server -- Trident display driver ii xserver-xorg-video-vesa-lts-quantal
1:2.3.2-0ubuntu1~precise1 X.Org X server -- VESA display driver ii xserver-xorg-video-vmware-lts-quantal
1:12.0.2+git.e5ac80d8-0ubuntu1~precise2 X.Org X server -- VMware display driver

share|improve this answer
    
ubfan1: It appears that the only "quantal" package on my system is the kernel: $ dpkg -l |fgrep quantal ii linux-image-generic-lts-quantal –  RadarDude Aug 12 '13 at 18:06
    
ubfan1: I noticed that you had "x11-xserver-utils-lts-quantal" so I started to install it. However, the install wanted to remove the ubuntu desktop, so I did not proceed further. Are you running the desktop? I was going to post the output here, but I ran out of "characters". –  RadarDude Aug 12 '13 at 18:15
    
The system seems to be running fine as it is, so I'll just use it this way. Hopefully I don't really need the new X stack?? –  RadarDude Aug 12 '13 at 18:16
    
I'm running the standard Unity desktop. If you're running OK, then leave it. I was surprised to see all the X packages, I thought there would be 3 kernel related quantal packages. –  ubfan1 Aug 12 '13 at 23:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.