Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am very new to ubuntu. Chose the option to load ubuntu alongside windows 7 from my flashdrive. When I was prompted to set the partition, I allowed it to do it automatically (to avoid issues... so much for that). Everything seemed to go fine but my pc now just boots into ubuntu 13.04 as if it is the only OS, there is no option to choose windows 7. I tried boot-repair (recommended settings option) to no avail. I haven't tried anything under the advanced options so that I won't make it worse before getting some feedback. Boot-repair supplied this paste bin: http://paste.ubuntu.com/5968556/

In the past, I had to have by pc repaired after a nasty virus. It's an HP pavillion 1230n that had windows xp originally, but when I got it after repairs it had windows 7 ultimate 7601 build (i think) anyway, it always had a pop up that I needed to get genuine windows. I also noticed Vista listed on my pastbin but I've never used vista on my pc.

I downloaded gparted but haven't made any changes.

I hope I've provided enough information. Any help would be greatly appreciated or just point me in the right direction. I've seen many similar posts with small differences and countless "solutions" however I don't know enough to be able to identify if what worked for them would work for me or make it harder for someone to help me.

Thanks in advance

Edit: @superweijiafeng sudo fdisk -l shows:

Disk /dev/sda: 200.0 GB, 200049647616 bytes
255 heads, 63 sectors/track, 24321 cylinders, total 390721968 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x1549f232

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1            2048    30722047    15360000    7  HPFS/NTFS/exFAT
/dev/sda2   *    30722048    30926847      102400    7  HPFS/NTFS/exFAT
/dev/sda3        30926848   316314777   142693965    7  HPFS/NTFS/exFAT
/dev/sda4       316315646   390721535    37202945    5  Extended
/dev/sda5       316315648   388757503    36220928   83  Linux
/dev/sda6       388759552   390721535      980992   82  Linux swap / Solaris

Disk /dev/sdb: 2003 MB, 2003795968 bytes
32 heads, 63 sectors/track, 1941 cylinders, total 3913664 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x2c46034e

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *          63     3913055     1956496+   6  FAT16

@superweijiafeng I never see any options to boot into vista or anything when booting. It just goes straight into Ubuntu. When I hit enter during booting to get into settings the only thing I can do is boot into ubuntu from hard drive or boot into ubuntu from my jump drive.

share|improve this question
    
Thanks for the suggestion superveijiafeng. I tried "sudo update-grub2" and my pc is still booting straight into Ubuntu. –  LRB Aug 11 '13 at 4:04
    
@superweijiafeng I never see any options to boot into vista or anything when booting. It just goes straight into Ubuntu. When I hit enter during booting to get into settings the only thing I can do is boot into ubuntu from hard drive or boot into ubuntu from my jump drive. –  LRB Aug 11 '13 at 5:31

1 Answer 1

Try sudo update-grub2, and restart to see if win7 appears.

If not, post the result of sudo fdisk -l

================================================

I notice that the origin ntfs partitions still exist.

By the way, have you try the vista entry or the others when booting?

================================================

open terminal sudo gedit /etc/default/grub

In the popup window, find the line GRUB_HIDDEN_TIMEOUT=0, add # before it or simply delete this line. Save and quit.

return to the terminal, sudo update-grub

reboot

share|improve this answer
    
@superweijiafengThe # was already there, so I just proceeded to sudo update-grub. When it was done, I rebooted and it went straight into Ubuntu like before. –  LRB Aug 11 '13 at 5:51
    
@LRB So... I don't know why. Maybe this link will help you. [link]help.ubuntu.com/community/Boot-Repair. Tell me if it works. –  superweijiafeng Aug 11 '13 at 6:00
    
I will have a look and report back –  LRB Aug 11 '13 at 6:04
    
I tried boot-repair before to no avail. I'll keep researching if I figure it out I will post it for others. –  LRB Aug 11 '13 at 6:33
    
I finally figured it out. My screen had an input out of range error. I thought when I set my screen in display in ubuntu that that was what it was referring to. Turns out I needed to fix it by doing something simular to what you suggested. I opened terminal and entered sudo gedit /edt/default/grub when the popup opened I found the line that said #GRUB_GFXMODE=640x480 and I just removed the # and saved exited the popup and typed sudo update-grub rebooted and it worked. I did notice when the grub menu finally came up that I can boot into win7 from sda2 and sda3...is this normal? –  LRB Aug 11 '13 at 9:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.