Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

In my college we have a LAN network through which we can access the Internet and DC++. This requires registration of a mac address which I have done.

Initially the network used to connect to the LAN (it showed that wired network was connected) but there was no Internet access. I restarted my machine with the network cable plugged in. This lead to an error displaying Device not configured. I fixed this by reading a question online.

Now my machine connects to the LAN with no Internet access. The network works fine on Windows.

ifconfig -a
eth0      Link encap:Ethernet  HWaddr b8:ca:3a:d7:67:f5  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:2818 errors:0 dropped:0 overruns:0 frame:0
          TX packets:197 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:210007 (210.0 KB)  TX bytes:11502 (11.5 KB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:1076 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1076 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:105216 (105.2 KB)  TX bytes:105216 (105.2 KB)

wlan0     Link encap:Ethernet  HWaddr 60:6c:66:86:81:c0  
          inet addr:192.168.150.107  Bcast:192.168.150.255  Mask:255.255.255.0
          inet6 addr: fe80::626c:66ff:fe86:81c0/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:18694 errors:0 dropped:0 overruns:0 frame:0
          TX packets:12035 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:22755906 (22.7 MB)  TX bytes:1269060 (1.2 MB)



 NetworkManager Tool

State: connected (global)

- Device: wlan0  [NTCC] --------------------------------------------------------
  Type:              802.11 WiFi
  Driver:            iwlwifi
  State:             connected
  Default:           yes
  HW Address:        60:6C:66:86:81:C0

  Capabilities:
    Speed:           72 Mb/s

  Wireless Properties
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes

  Wireless Access Points (* = current AP)
    Pln_Omini_1:     Infra, D4:CA:6D:9D:21:09, Freq 2447 MHz, Rate 54 Mb/s, Strength 25
    *NTCC:           Infra, FE:85:DE:78:5C:91, Freq 2462 MHz, Rate 54 Mb/s, Strength 80 WPA2
    Connectify-me:   Infra, 18:3D:A2:4A:BF:3D, Freq 2462 MHz, Rate 54 Mb/s, Strength 92 WPA2
    IRL-BITS:        Infra, 84:1B:5E:3A:33:86, Freq 2462 MHz, Rate 54 Mb/s, Strength 19 WPA2
    AndroidAP:       Infra, 20:02:AF:3B:91:84, Freq 2437 MHz, Rate 54 Mb/s, Strength 89 WPA2
    plasmodium:      Infra, C0:3F:0E:EB:87:48, Freq 2462 MHz, Rate 54 Mb/s, Strength 20 WPA2

  IPv4 Settings:
    Address:         192.168.150.107
    Prefix:          24 (255.255.255.0)
    Gateway:         192.168.150.1

    DNS:             192.168.150.1


- Device: eth0 -----------------------------------------------------------------
  Type:              Wired
  Driver:            r8169
  State:             unavailable
  Default:           no
  HW Address:        B8:CA:3A:D7:67:F5

  Capabilities:
    Carrier Detect:  yes
    Speed:           100 Mb/s

  Wired Properties
    Carrier:         off
share|improve this question
1  
Please edit your question to add the results of: nm-tool –  chili555 Aug 10 '13 at 19:13
    
@chili555 can you please guide me what command to run in the terminal. Thanks sorry I am a n00b –  tarun Aug 10 '13 at 19:25
    
Yes. Please run this command in the terminal: nm-tool. Sorry if I wasn't clear. –  chili555 Aug 10 '13 at 19:26
    
@chili555 done mate –  tarun Aug 10 '13 at 19:34
add comment

1 Answer

You seem to be connected by wireless but using the tricky driver iwlwifi. Please open a terminal and do:

sudo -i
echo "options iwlwifi 11n_disable=1" >> /etc/modprobe.d/iwlwifi.conf
exit

Reboot and let us hear your report.

share|improve this answer
    
still the same situation.Any other test you want me to do? –  tarun Aug 10 '13 at 19:48
    
can we please communicate on chat? I feel that would help faster. Also we can post the solution so other people can have a look. @chili555 –  tarun Aug 10 '13 at 20:06
    
Sure. Do you have a chat started? –  chili555 Aug 10 '13 at 20:32
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.