Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an ATI 4650 graphics card. And when i install the proprietary driver - there are glitches and blackness all over the screen. I've also read somewhere that ati cards don't work with 11.04 yet. Is it true? When will i be able to test 11.04 then?

P.S. By not working i mean - Unity doesn't work. The classic gnome shell works fine.

share|improve this question
add comment

7 Answers 7

up vote 6 down vote accepted

The open driver work from the archive (that gets set up by default) generally works on my ATI Fusion-based laptop. It's decently fast but not as fast as fglrx.

The fglrx drivers in the archive were faster, but would freeze my laptop once every few hours. The Catalyst 11.4 drivers that I manually installed from their website are the fastest and I've had no crashes yet.

Some people are reporting that disabling vsync has helped them:

share|improve this answer
    
following the instructions i completely trashed my system - now it doesn't have any graphical interface at all ;) –  die_humans Apr 4 '11 at 14:33
    
@die_humans Did you manage to get it working in the ends? –  Industrial Apr 27 '11 at 16:40
    
Interesting. I only had rendering glitches with the open "radeon" driver, they all went away with flgrx. –  Mark Russell Apr 29 '11 at 20:20
    
@die_humans see my note below about fglrx on my amd64 system. It completely trashed my system as well, but the open source driver got me back to being able to use Metacity (no effects) but not Compiz. –  Mojo May 2 '11 at 22:43
    
Oddly enough with catalyt 11.4 it works awesome for me in amd64. Go figure. –  Jorge Castro May 2 '11 at 22:56
add comment

i have a 4650mobility working in natty with fglrx ( atis proprietary driver ).

Notice : you MUST use the fglrx driver from within nattys repo and NOT use the *.run installers from amd.com/ati.com. The one in natty is a special pre-build version that can handle the new kernel and xserver.

Limitations : You cannot use unity or compiz , but unity-2d which gives you a similar experience,the dock and the globalmenu plus the ubuntu launcher :

Do this :

If you want to improve the look and feel to resemble unity3d closer you can activate metacitys own composite feature in gconf.This gives shadows and blur. Optional of course.

share|improve this answer
add comment

I use the amd64 architecture, and my VGA card is the RV710 Radeon HD 4550.

For me an fglrx seg fault in firegl_SetSuspectResumeState caused X to not even start up. After updating to Natty, I would get only an 80x25 text login: prompt.

I found the same links mentioned above to expunge fglrx and replace it with the open-source ATI driver. I also had to remove /etc/X11/xorg.conf.

This made it possible for the X login screen to appear, and I could log in using the "Ubuntu Classic (No effects)" option (i.e., Metacity window manager). All attempts to use Compiz, required for Ubuntu Classic or the Unity desktop, fail badly.

I have not been able to solve this problem at all.

Mojo

share|improve this answer
add comment

I have XFX HD-585X-ZAFC Radeon HD 5850 with i5-2500K and everything installed and working correctly.

share|improve this answer
add comment

My computer is a core i7 with ati HD 5000 series, and the unity interface run with a lot lags

i install the ".run"

i run: /usr/lib/nux/unity_support_test -p

OpenGL vendor string:   ATI Technologies Inc.
OpenGL renderer string: ATI Mobility Radeon HD 5400 Series 
OpenGL version string:  4.1.10666 Compatibility Profile Context

Not software rendered:    yes
Not blacklisted:          yes
GLX fbconfig:             yes
GLX texture from pixmap:  yes
GL npot or rect textures: yes
GL vertex program:        yes
GL fragment program:      yes
GL vertex buffer object:  yes
GL framebuffer object:    yes
GL version is 1.4+:       yes
share|improve this answer
add comment

It works with the open source driver.

I think the package name is xserver-xorg-video-ati

I also think you need to completely uninstall the binary driver.

Here are instructions from the ubuntu wiki about how to remove the binary driver and install the open source one

To quote it:

sudo /usr/share/ati/fglrx-uninstall.sh  # (if it exists)
sudo apt-get remove --purge fglrx*
sudo apt-get remove --purge xserver-xorg-video-ati xserver-xorg-video-radeon 
sudo apt-get install xserver-xorg-video-ati
sudo apt-get install --reinstall libgl1-mesa-glx libgl1-mesa-dri xserver-xorg-core
sudo dpkg-reconfigure xserver-xorg

Then reboot.

share|improve this answer
    
didn't work for me ( –  die_humans Apr 2 '11 at 21:06
    
maybe it's -radeon instead of -ati. make sure to run the dpkg-reconfigure command –  hasenj Apr 2 '11 at 22:21
    
For my laptop the open source driver runs about 30 degrees hotter while doing nothing, then the FLGRX making the open source driver simply not a solution unless I want to cook my laptop. –  trampster Apr 4 '11 at 0:19
add comment

I had glitches with the proprietary drivers after upgrading to 11.04. But the open source ones are working brilliantly in 11.04 with my ATI HD 5750 and 27" display (they didn't work at all on 10.10 for me). So there's a decent chance that it will work! Maybe try it out on USB first

share|improve this answer
    
How did you install the open source drivers? –  die_humans Apr 2 '11 at 13:38
2  
@die_humans: wiki.ubuntu.com/X/Troubleshooting/… –  hasenj Apr 2 '11 at 19:29
add comment

protected by Community May 7 '11 at 12:31

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.