Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I followed the DisklessUbuntuHowto and set up my pxe boot service. When configure the dhcp server in /etc/dhcp/dhcpd.conf, I tried to use static IP address as follows, in which "00:22:15:F8:D9:1A" is the mac address of the first network card in sms04 (it has two).

allow booting;
allow bootp;

subnet 192.168.0.0 netmask 255.255.255.0 {
  range 192.168.0.21 192.168.0.30;
  option broadcast-address 192.168.0.255;
  option routers 192.168.0.50;
  option domain-name-servers 192.168.0.50;

  filename "/pxelinux.0";
}

host sms04 {
  hardware ethernet 00:22:15:F8:D9:1A;
  fixed-address 192.168.0.25;
}

When I boot sms04 using the first network card, it can successfully get the IP 192.168.0.25 (static ip) and then load vmlinuz and initrd.

enter image description here

And then it failed with message IP-Config: no response after * secs - give up

enter image description here

Now, I try to pull out the cable in my first network card and plug in the second, after a while, it successfully boot up with dynamic IP address 192.168.0.21!

However, the dynamic IP address is unwanted. I try every method to boot from static IP, by failed.

I will appreciate any reply.

share|improve this question

1 Answer 1

I have spent a lot of time in this problem. So today I fixed it. Try to edit /etc/initramfs-tools/initramfs.conf and change: DEVICE= to DEVICE=eth0

See ya.

share|improve this answer
    
I fixed this problem by plug the cable into another network card (there were two network cards). However, there still existed several problems such as all computer had the same host name, and i have turn to the traditional boot up method. –  superweijiafeng Oct 11 '13 at 13:32
    
Any way, thanks for you reply, and I hope it could help other people. –  superweijiafeng Oct 11 '13 at 13:33
    
Yay, thanks, I've been bashing away at this one for a day until I found this. I could get static IP working but never DHCP, found several useless other suggestions but your's was the right one. –  Jason Morgan Nov 5 '13 at 16:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.