Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've created a simple shortcut.desktop in my Lubuntu 13.04 /usr/share/applications:

[Desktop Entry]
Type=Application
Name=shockwave
Icon=/home/zane/Pictures/Evil Decepticons.png
Exec=/home/zane/Documents/Zane_Shockwave-RDP.sh
Terminal=true
MimeType=text/plain
Categories=GTK;WebBrowser;Network

The pointed sh contains just echo "it works".

If I double-click the .desktop it directly, the script runs and everything works as expected.

But if I click the menu entry from the desktop, I just get a "stuck", non-inputable Terminal.

Note: to workaround this bug https://bugs.launchpad.net/ubuntu/+source/pcmanfm/+bug/975152/comments/14 I've just "lxterminal" under PCManFM -> Prefernces -> Advanced, otherwise I can't run .sh at all.

Any ideas?

Edit I also tried these variant, but I always get the same result:

Exec=sh /home/zane/Documents/Zane_Shockwave-RDP.sh
Exec=lxterminal /home/zane/Documents/Zane_Shockwave-RDP.sh
share|improve this question
up vote 1 down vote accepted

As suggested here, right-click and open the "Panel Settings"-dialog -> Advanced, then set "Terminal Emulator"="lxterminal" and now it works.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.