Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After I (painfully) managed to install Skype on my Ubuntu 12.04 LTS, I'm experiencing since months ago a packages issue I cannot fix.

Have a look to my last post in order to know what caused this issue: Install Skype on Ubuntu 12.04 LTS 64-bit

If I try to install system Updates the Update Manager closes unexpectedly stating that the package system is broken and throws the following error:

The following packages have unmet dependencies:

grub-efi-amd64: Depends: grub2-common (= 1.99-21ubuntu3.9) but 1.99-21ubuntu3.10 is installed
                Depends: grub-efi-amd64-bin (= 1.99-21ubuntu3.9) but 1.99-21ubuntu3.10 is installed

If I run sudo apt-get -f install in order to fix potential packages issues I get the following:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  linux-image-3.5.0-26-generic linux-headers-3.5.0-26
  linux-headers-3.5.0-26-generic
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  grub-efi-amd64
The following packages will be upgraded:
  grub-efi-amd64
1 upgraded, 0 newly installed, 0 to remove and 28 not upgraded.
2 not fully installed or removed.
Need to get 39.5 kB of archives.
After this operation, 0 B of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 http://archive.ubuntu.com/ubuntu/ precise-updates/main grub-efi-amd64 amd64 1.99-21ubuntu3.10 [39.5 kB]
Fetched 39.5 kB in 0s (154 kB/s)        
dpkg: dependency problems prevent configuration of grub-efi-amd64:
 grub-efi-amd64 depends on grub2-common (= 1.99-21ubuntu3.9); however:
  Version of grub2-common on system is 1.99-21ubuntu3.10.
 grub-efi-amd64 depends on grub-efi-amd64-bin (= 1.99-21ubuntu3.9); however:
  Version of grub-efi-amd64-bin on system is 1.99-21ubuntu3.10.
dpkg: error processing grub-efi-amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of grub-efi-amd64-signed:
 grub-efi-amd64-signed depends on grub-efi-amd64 (>= 1.99-21ubuntu3.5); however:
  Package grub-efi-amd64 is not configured yet.
dpkg: error processing grub-efi-amd64-signed (--configure):
 dependency problems - leaving unconfiguredNo apport report written because the error message indicates its a followup error from a previous failure.
                                                                     No apport report written because the error message indicates its a followup error from a previous failure.

Errors were encountered while processing:
 grub-efi-amd64
 grub-efi-amd64-signed
E: Sub-process /usr/bin/dpkg returned an error code (1)

If I run sudo dpkg --configure -a I get:

dpkg: dependency problems prevent configuration of grub-efi-amd64:
 grub-efi-amd64 depends on grub2-common (= 1.99-21ubuntu3.9); however:
  Version of grub2-common on system is 1.99-21ubuntu3.10.
 grub-efi-amd64 depends on grub-efi-amd64-bin (= 1.99-21ubuntu3.9); however:
  Version of grub-efi-amd64-bin on system is 1.99-21ubuntu3.10.
dpkg: error processing grub-efi-amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of grub-efi-amd64-signed:
 grub-efi-amd64-signed depends on grub-efi-amd64 (>= 1.99-21ubuntu3.5); however:
  Package grub-efi-amd64 is not configured yet.
dpkg: error processing grub-efi-amd64-signed (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 grub-efi-amd64
 grub-efi-amd64-signed

My understanding is that the root cause is unmet dependecies of packages grub-efi-amd64 and grub-efi-amd64-signed, so I have tried what is described here How do I resolve unmet dependencies? but the problem still persist.

I'm not sure if the removal of the conflicting packages would fix the issue, but I haven't done it yet as I'm afraid I could ruin my system as it has EFI boot and I'm booting it with GRUB. For the same reason I haven't tried to run sudo apt-get -u dist-upgrade, as perhaps the conflicting packages could be automatically removed.

I'd like to know if others have had a similar experience as well as possible solutions to this.

Just as additional info this is the output of gedit /etc/apt/sources.list:

# deb cdrom:[Ubuntu 12.04.2 LTS _Precise Pangolin_ - Release amd64 (20130213)]/ dists/precise/main/binary-i386/

# deb cdrom:[Ubuntu 12.04.2 LTS _Precise Pangolin_ - Release amd64 (20130213)]/ dists/precise/restricted/binary-i386/
# deb cdrom:[Ubuntu 12.04.2 LTS _Precise Pangolin_ - Release amd64 (20130213)]/ precise main restricted

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://archive.ubuntu.com/ubuntu precise main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://archive.ubuntu.com/ubuntu precise-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://archive.ubuntu.com/ubuntu precise universe
deb http://archive.ubuntu.com/ubuntu precise-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
## team, and may not be under a free licence. Please satisfy yourself as to 
## your rights to use the software. Also, please note that software in 
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://archive.ubuntu.com/ubuntu precise multiverse
deb http://archive.ubuntu.com/ubuntu precise-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.

deb http://archive.ubuntu.com/ubuntu precise-security main restricted
deb http://archive.ubuntu.com/ubuntu precise-security universe
deb http://archive.ubuntu.com/ubuntu precise-security multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
deb http://archive.canonical.com/ubuntu precise partner
deb-src http://archive.canonical.com/ubuntu precise partner

## This software is not part of Ubuntu, but is offered by third-party
## developers who want to ship their latest software.
# deb http://extras.ubuntu.com/ubuntu precise main
# deb-src http://extras.ubuntu.com/ubuntu precise main
deb http://archive.canonical.com/ precise partner
deb-src http://archive.canonical.com/ precise partner

And gedit /etc/apt/sources.list.d/* (different files):

deb-src http://ppa.launchpad.net/cassou/emacs/ubuntu precise main

### THIS FILE IS AUTOMATICALLY CONFIGURED ###
# You may comment out this entry, but any other modifications may be lost.
deb http://dl.google.com/linux/chrome/deb/ stable main

### THIS FILE IS AUTOMATICALLY CONFIGURED ###
# You may comment out this entry, but any other modifications may be lost.
deb http://dl.google.com/linux/chrome/deb/ stable main

deb http://ppa.launchpad.net/guilhem-fr/swftools/ubuntu precise main
deb-src http://ppa.launchpad.net/guilhem-fr/swftools/ubuntu precise main

deb-src http://ppa.launchpad.net/rabbitvcs/ppa/ubuntu precise main

deb http://ppa.launchpad.net/yannubuntu/boot-repair/ubuntu precise main
deb-src http://ppa.launchpad.net/yannubuntu/boot-repair/ubuntu precise main

deb http://ppa.launchpad.net/yannubuntu/boot-repair/ubuntu precise main
deb-src http://ppa.launchpad.net/yannubuntu/boot-repair/ubuntu precise main
share|improve this question
add comment

2 Answers 2

Simple install synaptic package manager and under Status (to the left) click on broken packages- select those packages & fix it or re-install them.

share|improve this answer
    
Won't work, I get this either way: E: grub-efi-amd64: dependency problems - leaving unconfigured E: grub-efi-amd64-signed: dependency problems - leaving unconfigured –  Alejandro García Seco Aug 9 '13 at 10:50
    
You seem to have added other repositories to your update manager. try not to add any third party (if your not sure) also untick unsupported updates/ pre-release updates from update manager. check this out for more information google.co.in/… –  Kanthala Raghu Aug 9 '13 at 10:57
    
I have always had disabled "updates/ pre-release updates" in the update manager. Disabling third party repositories the outcome is the same. –  Alejandro García Seco Aug 9 '13 at 11:14
add comment
up vote 0 down vote accepted

I finally solved my issue by removing with Synaptic the problematic packages grub-efi-amd64 and grub-efi-amd64-signed.

After that, I installed and applied all the pending system updates which seem to have installed again the mentioned packages.

Once all the update process finished I rebooted the system and everything is fine now.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.