Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

With my current (and favorite) theme the Unity panel is black text on a black background. Is there a way to set the font color in Unity or the theme somehow?

share|improve this question
    
I know that this is an old thread, but since it hasn't been closed... This issue persists in 12.04. Changing text[NORMAL] property changes other text as well, which is problematic. I am able to change it changing the theme and icons using myunity, but those changes are not persistent. They only seem to last for the session. Looks like a bug report was filed and resolved in 2010, but the problem is still present on my quite up-to-date machine. The dark text on a dark background makes unity unusable for me. Too bad, because I like it otherwise. –  user115017 Dec 16 '12 at 15:11

2 Answers 2

The panel text uses the color defined by the theme's text[NORMAL] property. You'll likely find that in the file /usr/share/themes/<theme>/gtk-2.0/gtkrc.

Note, that this doesn't affect the home button and indicator icon color. For that you'd have to change the icon set used by your theme (in Appearance PropertiesTheme tab).

share|improve this answer

Use GTK Theme Preferences...

Code:

sudo add-apt-repository ppa:shimmerproject/ppa

sudo apt-get update

sudo apt-get install gtk-theme-config

Also add your current panel background color when you change panel text color. Install gcolor2 for the old style color picker to copy your panel color or look in your theme.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.