Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have wiped Windows and installed Ubuntu 10.04 on an HP Pavilion zv5000.

I find that my wireless is turned off every time I reboot. I can get it to turn on again by running the following commands which, as a Linux newbie, I only sort of understand:

$ sudo modprobe -r b43 ssb b43 -v
rmmod /lib/modules/2.6.32-50-generic/kernel/drivers/net/wireless/b43/b43.ko
rmmod /lib/modules/2.6.32-50-generic/kernel/drivers/ssb/ssb.ko
rmmod /lib/modules/2.6.32-50-generic/kernel/net/mac80211/mac80211.ko
rmmod /lib/modules/2.6.32-50-generic/kernel/net/wireless/cfg80211.ko
rmmod /lib/modules/2.6.32-50-generic/kernel/drivers/leds/led-class.ko
$ sudo modprobe b43 -v
insmod /lib/modules/2.6.32-50-generic/kernel/drivers/leds/led-class.ko 
insmod /lib/modules/2.6.32-50-generic/kernel/net/wireless/cfg80211.ko 
insmod /lib/modules/2.6.32-50-generic/kernel/net/mac80211/mac80211.ko 
insmod /lib/modules/2.6.32-50-generic/kernel/drivers/ssb/ssb.ko 
insmod /lib/modules/2.6.32-50-generic/kernel/drivers/net/wireless/b43/b43.ko

I see that the first command removes some modules and then the following command installs the modules again in reverse order. I am glad this makes the wireless work, but I don't understand why it does, and I would really rather have the wireless work properly without having to do this after every reboot.

If it helps with troubleshooting, I get the following wireless info when I run:

$ lspci -vnn -d 14e4:
02:02.0 Network controller [0280]: Broadcom Corporation BCM4306 802.11b/g Wireless LAN Controller [14e4:4320] (rev 03)
    Subsystem: Hewlett-Packard Company Device [103c:12f4]
    Flags: bus master, fast devsel, latency 64, IRQ 17
    Memory at e0104000 (32-bit, non-prefetchable) [size=8K]
    Kernel driver in use: b43-pci-bridge
    Kernel modules: ssb

I have seen some posts with similar issues with Broadcom wireless controllers, and I have tried doing some of the things that have been recommended without success. One thing I keep reading about, which may or may not be an issue is blacklisting the ssb module. However, I don't know how to do that.

Any help is appreciated!

share|improve this question
1  
Consider upgrading to a more current release. Check the /etc/modules for any related entries, and remove them if present. I recall the only thing needed for the b43 driver was to supply the firmware to make it work. –  ubfan1 Aug 9 '13 at 0:15
    
If you blacklist ssb your wireless will not work and broadcom based ehternet cards will not work either. Reboot and see if just sudo modprobe b43 makes your wireless work if so I will post the answer if not we can right a script so it will run those two commands when you boot automatically. –  Wild Man Aug 9 '13 at 0:20
    
Also include the output of ls /etc/modprobe.d/ –  Braiam Aug 12 '13 at 17:58
add comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.