Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed maas server and configured juju also, And bootstrapped juju for 1st time, which I know will install zookeeper on 1 "ready" state VM available in MAAS.

So I observed this installation, it installed OS and the rebooted and came to this screen and since then its stuck,

enter image description here

enter image description here

Error command failed: cannot inject a machine without a instance id
errors running cloud_config [final]: [scripts-user]

What are these errors? How can I resolve them? I am running 12.04.2 LTS, juju version is 1.13.1-precise-amd64 and maas version - 1.3.1

I also checked juju status -v, its gives following message continuously:

2013-08-08 16:31:17 INFO juju open.go:107 state: connection established
2013-08-08 16:31:17 INFO juju conn.go:64 juju: authorization error while connecting to state server; retrying
2013-08-08 16:31:17 INFO juju open.go:69 state: opening state; mongo addresses: ["pxp7m.master:37017"]; entity ""
2013-08-08 16:31:17 INFO juju open.go:107 state: connection established
2013-08-08 16:31:18 INFO juju open.go:69 state: opening state; mongo addresses: ["pxp7m.master:37017"]; entity ""
2013-08-08 16:31:18 INFO juju open.go:107 state: connection established
2013-08-08 16:31:18 INFO juju open.go:69 state: opening state; mongo addresses: ["pxp7m.master:37017"]; entity ""
share|improve this question
    
Every so often Juju fails at first start-up. If you haven't tried to juju destroy-environment -v and redo your juju bootstrap -v again after 5 minutes or so of a wait. Use with the -v marker to see whats going on. –  Brandon Clark Aug 8 '13 at 19:20
    
its same error, here is output of bootsrap juju bootstrap -v INFO juju tools.go:75 environs: picked newest version: 1.10.0 INFO juju tools.go:25 environs: reading tools with major version 1 INFO juju tools.go:52 environs: filtering tools by series: precise INFO juju tools.go:60 environs: filtering tools by version: 1.10.0 WARNING juju.environs.maas environ.go:230 picked arbitrary tools &{"1.10.0-precise-amd64" "192.168.34.20/MAAS/api/1.0/files/…;} INFO juju supercommand.go:276 command finished –  SaM Aug 8 '13 at 21:05
    
I have tried bootstrap so many times, and still same issue. –  SaM Aug 9 '13 at 8:40
    
This appears to be a cloud-init problem, not MAAS, I'll have one of them respond to your question! –  Jorge Castro Aug 9 '13 at 9:30
    
If you could add the versions of Juju, MAAS, and Ubuntu to your question that would also be helpful, thanks! –  Jorge Castro Aug 9 '13 at 9:31

2 Answers 2

This looks like an issue with finding appropriate tools. The juju client you said you were using was 1.13.1, but the tools it is finding is for 1.10. These will almost certainly not work.

There is a sync-tools command that will get the latest tools from the public location to put into the local tools bucket.

share|improve this answer
    
Could you please elaborate how to solve this? –  Braiam Aug 15 '13 at 0:01
    
@Braiam There's a tool, juju sync-tools that you can use to pull/push tools –  Marco Ceppi Oct 25 '13 at 17:14
up vote -1 down vote accepted

i have no clue how, i followed same procedure - which i was using earlier and did everything again from scratch (might 6th or 7th time) and it worked, but i am suspecting there were few updates in juju package this time, which might have resolved my issue.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.