Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

After an update yesterday, every time I try to run gajim or cardapio, this is what I get:

(process:10142): Gtk-WARNING **: Locale not supported by C library. Using the fallback 'C' locale.

I tried reinstalling cardapio and I'm still getting the problem. Since both are written in python I was guessing it must be a problem with python but I can't see which update could have caused this problem. I'm at a loss as to what to do, since nothing in my searching has proven useful (a bunch of unanswered forum posts for what seems to be a similar, but non-fatal error).

EDIT: After following this answer locale problem when running xterm in Ubuntu 10.04, I am still at a loss as to a fix. I can launch the applications with LANG=C, but, I don't quite get how to make that default (if this is needed).

EDIT#2 In seeking a solution, I tried to run clicompanion, and this is what I get: Traceback (most recent call last): File "/usr/bin/clicompanion", line 27, in <module> idioma = get_language() File "/usr/bin/clicompanion", line 18, in get_language loc = locale.setlocale(locale.LC_ALL, "") File "/usr/lib/python2.6/", line 513, in setlocale return _setlocale(category, locale) locale.Error: unsupported locale setting

share|improve this question
up vote 0 down vote accepted

Not 100% sure what in my sequence fixed the problem, but nothing I tried worked - until:

  • I reinstalled the locales (language-support-*)
    • This did not fix the problem, as far as I could tell, but at this point I had not logged out.
  • Logged out, logged in without changing anything.
    • this did not fix the problem, it would seem, as I still got an error.
  • I logged out, changed the language I was logging in with, and logged into the recovery console to test again.
    • Somehow the problem seems to have fixed itself.
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.