Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using ubuntu 12.04

I installed php pear using this command

sudo apt-get install php-pear php5-dev

I got this results

Reading package lists... Done
Building dependency tree       
Reading state information... Done
php-pear is already the newest version.
php5-dev is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Now when I use this command

sudo pecl install v8js-0.1.3

I'm getting this error

sudo: pecl: command not found

Can someone tell me how to fix this error? Thankyou

share|improve this question
    
sudo apt-get install -f php-pear php5-dev could possibly do it –  SimplySimon Aug 8 '13 at 16:39
    
I still got the same message.. 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded. –  Giri Aug 8 '13 at 16:50

3 Answers 3

Fire up a terminal and use:

sudo apt-get update
sudo apt-get install php-pear php5-dev
share|improve this answer
    
I've done all the steps. But nothing works. I still getting that same message. 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded. –  Giri Aug 8 '13 at 17:00

check your enviroment variable. /etc/environment. it should be like that PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games"

share|improve this answer

This is what I did.

I completely remove old packages using

sudo apt-get purge php-pear

Then installed pear using the following command

sudo apt-get install -f php-pear php5-dev

Now it works.

Thanks

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.