Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I installed Ubuntu 13.04 while Windows 7 dual booted. I have a Local wired cable connection which is working fine with windows 7, but in the case of Ubuntu it is not working. I try to connect using Network Connections and Ipv4 Settings, in Method option. I use Manual and put all the addresses which my Internet Service Provider has given to me, but whenever I am going to save the Save... button grayed out. I have collected some data regarding this issue. using,

lspci -nnk | grep -iEA3 "(network|wireless|ethernet)"

it shows,

03:00.0 Network controller [0280]: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) [168c:002b] (rev 01)
    Subsystem: AzureWave AW-NB037H 802.11bgn Wireless Half-size Mini PCIe Card [AR9002WB-1NGCD] [1a3b:2c37]
    Kernel driver in use: ath9k
04:00.0 USB controller [0c03]: ASMedia Technology Inc. ASM1042 SuperSpeed USB Host Controller [1b21:1042]
    Subsystem: ASUSTeK Computer Inc. Device [1043:1059]
--
05:00.0 Ethernet controller [0200]: Qualcomm Atheros AR8151 v2.0 Gigabit Ethernet [1969:1083] (rev c0)
    Subsystem: ASUSTeK Computer Inc. Device [1043:1851]
    Kernel driver in use: atl1c

and

sudo ifconfig

it shows,

eth0      Link encap:Ethernet  HWaddr c8:60:00:43:c7:82  
          inet6 addr: fe80::ca60:ff:fe43:c782/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:985 errors:0 dropped:16 overruns:0 frame:0
          TX packets:32 errors:0 dropped:0 overruns:0 carrier:1
          collisions:0 txqueuelen:1000 
          RX bytes:71604 (71.6 KB)  TX bytes:6652 (6.6 KB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:144 errors:0 dropped:0 overruns:0 frame:0
          TX packets:144 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:11744 (11.7 KB)  TX bytes:11744 (11.7 KB)

wlan0     Link encap:Ethernet  HWaddr 00:08:ca:f0:51:5a  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

Can anyone suggest how I can fix this and connect to my wired connection?

share|improve this question
    
You are using static IP or have DHCP service. – Gaurav Sharma Aug 8 '13 at 11:51
up vote 1 down vote accepted

It seems that you do not have an IPv4 address. To set this:

First, open the terminal, and then type the following:

sudo nano /etc/network/interfaces

This will open a file, type the following in the file:

auto eth0
iface eth0 inet static
    address 192.168.1.100
    netmask 255.255.255.0
    network 192.168.1.0
    broadcast 192.168.1.255
    gateway 192.168.1.1

(Enter your own IP addresses instead the above.) Or, if you do not want a static IP, just type the following lines in the file:

auto eth0
iface eth0 inet dhcp

Save the file (CTL+X, Y, enter) and restart the network service:

sudo service network-manager restart

Hope this helps.

share|improve this answer

I had the same problem. Then I figured out that some settings in Windows may prohibit internet connections in Ubuntu. I disabled Wake-On-LAN in power management in Windows 8, and now it works in Ubuntu.

share|improve this answer

I also encountered this on a dual boot after upgrading Windows 7 to Windows 10. I was having the issue that Ubuntu could not mount a NTFS partition meant to be shared by both OS's. (Ref Failed to access Windows 8.1 NTFS partition from ubuntu 13.10, even after disable fast startup )

I turned off Fast Startup in Win10. This fixed the shared partition and at the same time resolved the Ethernet connection issue. I am not sure why they would be related but it worked for me so it may be worth a try.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.