Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After reviewing many guides about kernel upgrades - and even following a tip from: http://syntaxionist.rogerhub.com/ubuntu-on-the-lenovo-thinkpad-x230.html to upgrade the kernel of Ubuntu 12.04 to 3.4, I still experiencing problems with my Bluetooth (really laggy for sound, and keyboard will not stay connected), I'm considering upgrading to a current kernel (for example 3.9 or 3.10).

This is the question that I don't understand:

From the kernel list in the Ubuntu repository - http://kernel.ubuntu.com/~kernel-ppa/mainline/ the latest kernel for 12.04 (precise) is 3.4.

Is it OK to install a kernel that is above 3.4 on ubuntu 12.04 like 3.10?

Thanks.

share|improve this question

1 Answer 1

From the kernel list in the Ubuntu repository - http://kernel.ubuntu.com/~kernel-ppa/mainline/ the latest kernel for 12.04 (precise) is 3.4.

These are just names.

At this time, the latest available Ubuntu kernel for 12.04 is 3.8. The mainline kernels are not suggested for installation, except if you are doing tests or you experience a major problem that it can be resolved with a specific mainline kernel. Please read more about mainline kernels here.

Because of the LTS feature of 12.04 many different kernels will be backported from newer versions of Ubuntu and X-stack as well. The 12.04.3 version (that will be released in 22 August 2013) will have 3.8 kernel and X-stack all backported from Ubuntu 13.04 (raring).

As I said, the latest available Ubuntu kernel is 3.8 and you can install it in 12.04 from a terminal. (or a GUI package manager, e.g synaptic, software center).

Open a terminal (CTRL+ALT+T) and issue the following commands

sudo apt-get install linux-image-generic-lts-raring
sudo apt-get install linux-headers-generic-lts-raring

When the installation completes, reboot your system to boot from 3.8 kernel. Grub bootloader always list the newer kernel first, so it will boot from 3.8 automatically (except if you have installed a newer than 3.8).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.