Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I had a 16gb flashdrive in which I installed Ubuntu (using my Dell laptop) the first partition was of 8gb NTFS, the 2nd of ext4 of 7.3GB rest as SWAP. I made this portable OS as a universal OS that can provide me a plug n play OS anywhere I go.

I soon bought a 32gb flashdrive & wanted to clone the upper OS flash to this one. So I used clonezilla to make an image, using gparted manually partitioned the 32gb flash such that the first partition is of 20gb NTFS, 2nd 8.5gb ext4 rest as SWAP. Then cloned the image of a 16gb flash onto a manually partitioned 32gb flash. All of the actions performed in this paragraph were via my Acer laptop under Ubuntu 12.10. (While in clonezilla I check -r flag & opted for k option which says don't write new partition table on destination )

The 32gb flash was ready to use & I tried booting it up after a restart. When the screen showed up everything was fine but my first NTFS partition was not showing 20gb of space rather 8gb (the size of the parent 16gb flash) thus I formatted this partition using gparted which seemingly gave me 20gb NTFS space...

Now the problem is machine specific booting? My 16gb flash booted with ease which ever laptop I tried to boot it from acer/dell/desktop... But this clone 32gb had some serious issues while booting. I boot it with ease on my dell laptop the very laptop I used to install Linux onto 16gb flash, but on acer as well as ony my desktop PC it says grub rescue unknown filesystem?

Solutions I tried so far:

On my acer laptop while in Ubuntu I plug in 32gb flash (giving me the headache) open up gparted, unmounted all partitions of sbd (32gb flash) performed check on both NTFS & ext4 no errors reported... I tried to boot again from my 32gb flash & it did boot without any problem on my acer.

After shutting down I booted it from dell laptop again no problem, then after dell laptop I rechecked it to boot from acer laptop & again I faced that problem of grub rescue & such...

Now whenever I have to boot it from acer after having booted it from my dell laptop I have to either perform check on its NTFS drive using gparted or don't insert it in my dell laptop at all?

I also tried clearing off it its grub using

dd if=/dev/zero of=/dev/sda bs=446 count=1

& then reinstalled grub but to no avail. Thus this machine specific booting problem not faced on 16gb flash renders my primary purpose of plug n play OS as a failure

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.