Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have followed up to getting an Ubuntu Touch. But I cannot get Ubuntu SDK.

• OS: Ubuntu 12.04 64-bit
• Language: Korean

I opened the terminal and ran sudo add-apt-repository ppa:ubuntu-sdk-team/ppa && sudo apt-get install ubuntu-sdk and I got the following results:

gpg: key C7122F9B: public key "Launchpad PPA for Ubuntu SDK team" imported
gpg: Total number processed: 1
gpg:               imported: 1 (RSA: 1)
OK
...
E: could not find ubuntu-sdk

What's wrong?

share|improve this question
1  
you need to do sudo apt-get update before you install the new package... –  Alvar Aug 8 '13 at 6:12
add comment

1 Answer 1

You have to tell your system to pull down the latest list of software from each archive it knows about, including the PPA you just added by running sudo apt-get update before you can install any package from a newly added PPA. Open the terminal and run:

sudo add-apt-repository ppa:ubuntu-sdk-team/ppa
sudo apt-get update
sudo apt-get install ubuntu-touch-meta qtcreator qtcreator-plugin-ubuntu-common 

To start Ubuntu SDK, just type Ubuntu SDK in the Dash and click on the icon that has the title Ubuntu SDK under it.

If you have Ubuntu 13.04 or Ubuntu 13.10, it is easier to install Ubuntu SDK. Just open the Ubuntu Software Center, search for Ubuntu SDK and install the ubuntu-sdk package. This will also install a long list of dependencies required to install ubuntu-sdk. Thanks for the comments from Pregene Cho and everyone else who helped.

share|improve this answer
    
I tried again after run to update repository. (used 'sudo apt-get update') But, same result. additional system info: kernel: linux 3.5.0-37-generic, gnome : 3.4.2, memory : 8G, processor : Intel(R) Core(TM) i7 CPU 870 @ 2.93GHz x 8, os : ubuntu 12.04 LTS (64bit) –  Pregene Cho Aug 8 '13 at 7:09
    
I checked the ubuntu-sdk-team PPA and as you said the ubuntu-sdk package is not in that PPA. So how did that happen? I tried to track this thing down & incredibly in order to start Ubuntu SDK from the Dash you have to start an application called qtcreator which is in the ubuntu-sdk-team PPA. There is a tutorial about how to do this here with a picture in it showing how to start Ubuntu SDK from the Dash. That still doesn't answer the question of EXACTLY which packages to install. ALL of them? –  karel Aug 8 '13 at 7:38
    
@PregeneCho By ALL of them I mean all of the relevant packages from this webpage. I counted them, there are about 42 different packages, and some of the packages are only available as source code. –  karel Aug 8 '13 at 7:49
    
succeed to install ubuntu sdk via ubuntu software center application. –  Pregene Cho Aug 8 '13 at 8:01
    
@PregeneCho Please write an answer telling what you did to install Ubuntu SDK and click the check mark to the left of it to accept it and then I'll delete my answer and also upvote yours. Or else click the check mark to the left of my answer to accept it and I'll edit it and put in your comment and also the part about qtcreator. –  karel Aug 8 '13 at 8:16
show 5 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.