Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have recently updated to ubuntu 10.10 on my Dell Studio 1555

The wifi works perfectly in ubuntu 10.04

but in Ubuntu 10.10 I can't connect at all.

By default I have no wifi at all

System->Administration->Additional Drivers gives two driver options:

Broadcom B43 wireless driver
Broadcom STA wireless driver

The STA driver shows as disconnected no matter what I do. And doesn't detect any networks. The B43 driver sees the network but tries to connect forever despite the correct password and Wireless security settings. (I know the password works as I have other computers on the network)

I know the card works because I have windows vista dual booting and it can use the wifi fine.

How can I get my wifi working?

share|improve this question

2 Answers 2

up vote 0 down vote accepted

I solved this by black listing the B43 driver and installing the STA driver.

share|improve this answer

I solved the problem by utilizing STA driver and WICD instead of the standard Network Manager.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.