Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Sager np8290 laptop with NVidia geforce GTX 770m (optimus). I'm currently trying to get bumblebee to work with Ubuntu 13.04. Through all the mess, and fresh system installs, I have been able to get bumblebee to work I believe, because I can run the optirun's glxspheres and it works fine. I can't run bbswitch though. I know the main Nvidia card is running constantly because the computer is getting very hot and the fan keeps revving.

Running sudo modprobe bbswitch gives

ERROR: could not insert 'bbswitch': No such device

And running bumblebeed -vv gives

[ 2433.048330] [DEBUG]Found card: 01:00.0 (discrete)
[ 2433.048343] [DEBUG]Found card: 00:02.0 (integrated)
[ 2433.048346] [DEBUG]Reading file: /etc/bumblebee/bumblebee.conf
[ 2433.048534] [INFO]Configured driver: nvidia
[ 2433.048541] [DEBUG]Skipping auto-detection, using configured driver 'nvidia'
[ 2433.048604] [DEBUG]Process /sbin/modprobe started, PID 23369. 
[ 2433.048641] [DEBUG]Hiding stderr for execution of /sbin/modprobe
[ 2433.049564] [DEBUG]SIGCHILD received, but wait failed with No child processes
[ 2433.049710] [INFO]Loading driver bbswitch (module bbswitch)
[ 2433.049765] [DEBUG]Process modprobe started, PID 23370.
ERROR: could not insert 'bbswitch': Operation not permitted
[ 2433.050644] [DEBUG]Process with PID 23370 returned code 1    
[ 2433.050735] [ERROR]Module bbswitch could not be loaded (timeout?)
[ 2433.050739] [DEBUG]bbswitch is not available, perhaps you need to insmod it?
[ 2433.050742] [INFO]Skipping switcheroo PM method because it is not explicitly     selected in the configuration.
[ 2433.050746] [WARN]No switching method available. The dedicated card will always be on.
[ 2433.050749] [DEBUG]Active configuration:
[ 2433.050751] [DEBUG] bumblebeed config file: /etc/bumblebee/bumblebee.conf
[ 2433.050754] [DEBUG] X display: :8
[ 2433.050757] [DEBUG] LD_LIBRARY_PATH: /usr/lib/nvidia-325:/usr/lib32/nvidia-325
[ 2433.050760] [DEBUG] Socket path: /var/run/bumblebee.socket
[ 2433.050763] [DEBUG] pidfile: /var/run/bumblebeed.pid
[ 2433.050766] [DEBUG] xorg.conf file: /etc/bumblebee/xorg.conf.nvidia
[ 2433.050768] [DEBUG] xorg.conf.d dir: /etc/bumblebee/xorg.conf.d
[ 2433.050771] [DEBUG] ModulePath: /usr/lib/nvidia-325/xorg,/usr/lib/xorg/modules
[ 2433.050774] [DEBUG] GID name: bumblebee
[ 2433.050777] [DEBUG] Power method: auto
[ 2433.050780] [DEBUG] Stop X on exit: 1
[ 2433.050783] [DEBUG] Driver: nvidia
[ 2433.050785] [DEBUG] Driver module: nvidia-325
[ 2433.050788] [DEBUG] Card shutdown state: 1
[ 2433.050844] [DEBUG]Process /sbin/modprobe started, PID 23371.
[ 2433.050886] [DEBUG]Hiding stderr for execution of /sbin/modprobe
[ 2433.051741] [DEBUG]SIGCHILD received, but wait failed with No child processes
[ 2433.051748] [DEBUG]Configuration test passed.
[ 2433.051766] [ERROR]Cannot open or write pidfile /var/run/bumblebeed.pid.`

Also, dmesg | grep bbswitch gives

[    2.604556] bbswitch: module verification failed: signature and/or required key missing - tainting kernel
[    2.606299] bbswitch: version 0.7
[    2.606303] bbswitch: Found integrated VGA device 0000:00:02.0: \_SB_.PCI0.GFX0
[    2.606307] bbswitch: cannot find ACPI handle for VGA device 0000:01:00.0
[    2.606309] bbswitch: No discrete VGA device found
[    2.620803] bbswitch: version 0.7
[    2.620809] bbswitch: Found integrated VGA device 0000:00:02.0: \_SB_.PCI0.GFX0
[    2.620812] bbswitch: cannot find ACPI handle for VGA device 0000:01:00.0
[    2.620814] bbswitch: No discrete VGA device found
[    2.632556] bbswitch: version 0.7
[    2.632562] bbswitch: Found integrated VGA device 0000:00:02.0: \_SB_.PCI0.GFX0
[    2.632566] bbswitch: cannot find ACPI handle for VGA device 0000:01:00.0
[    2.632569] bbswitch: No discrete VGA device found
[    2.643909] bbswitch: version 0.7
[    2.643914] bbswitch: Found integrated VGA device 0000:00:02.0: \_SB_.PCI0.GFX0
[    2.643918] bbswitch: cannot find ACPI handle for VGA device 0000:01:00.0
[    2.643920] bbswitch: No discrete VGA device found
[    2.652674] bbswitch: version 0.7
[    2.652678] bbswitch: Found integrated VGA device 0000:00:02.0: \_SB_.PCI0.GFX0
[    2.652682] bbswitch: cannot find ACPI handle for VGA device 0000:01:00.0
[    2.652683] bbswitch: No discrete VGA device found
[    2.680709] bbswitch: version 0.7
[    2.680714] bbswitch: Found integrated VGA device 0000:00:02.0: \_SB_.PCI0.GFX0
[    2.680717] bbswitch: cannot find ACPI handle for VGA device 0000:01:00.0
[    2.680719] bbswitch: No discrete VGA device found
[    2.691707] bbswitch: version 0.7
[    2.691711] bbswitch: Found integrated VGA device 0000:00:02.0: \_SB_.PCI0.GFX0
[    2.691713] bbswitch: cannot find ACPI handle for VGA device 0000:01:00.0
[    2.691715] bbswitch: No discrete VGA device found
[    2.700902] bbswitch: version 0.7
[    2.700907] bbswitch: Found integrated VGA device 0000:00:02.0: \_SB_.PCI0.GFX0
[    2.700910] bbswitch: cannot find ACPI handle for VGA device 0000:01:00.0
[    2.700912] bbswitch: No discrete VGA device found
[    2.711751] bbswitch: version 0.7
[    2.711755] bbswitch: Found integrated VGA device 0000:00:02.0: \_SB_.PCI0.GFX0
[    2.711758] bbswitch: cannot find ACPI handle for VGA device 0000:01:00.0
[    2.711760] bbswitch: No discrete VGA device found
[    2.724398] bbswitch: version 0.7
[    2.724403] bbswitch: Found integrated VGA device 0000:00:02.0: \_SB_.PCI0.GFX0
[    2.724429] bbswitch: cannot find ACPI handle for VGA device 0000:01:00.0
[    2.724433] bbswitch: No discrete VGA device found
[    2.752170] bbswitch: version 0.7
[    2.752176] bbswitch: Found integrated VGA device 0000:00:02.0: \_SB_.PCI0.GFX0
[    2.752179] bbswitch: cannot find ACPI handle for VGA device 0000:01:00.0
[    2.752181] bbswitch: No discrete VGA device found
[ 1369.306337] bbswitch: version 0.7
[ 1369.306343] bbswitch: Found integrated VGA device 0000:00:02.0: \_SB_.PCI0.GFX0
[ 1369.306349] bbswitch: cannot find ACPI handle for VGA device 0000:01:00.0
[ 1369.306352] bbswitch: No discrete VGA device found
[ 2356.234401] bbswitch: version 0.7
[ 2356.234406] bbswitch: Found integrated VGA device 0000:00:02.0: \_SB_.PCI0.GFX0
[ 2356.234409] bbswitch: cannot find ACPI handle for VGA device 0000:01:00.0
[ 2356.234412] bbswitch: No discrete VGA device found`

I am running the updated kernel now

$ uname -r
3.9.4-030904-generic

I have no other idea why I can't get bbswitch to run. I would like to turn off the Nvidia card to prevent it from getting so hot!

Any ideas, or links to other solutions would be appreciated.

share|improve this question
    
I got the same issue with a Dell Latitude E6530. For me the workarounds for brightness settings (ACPI kernel parameters) were not compatible with bbswitch. Could you please post the output of cat /proc/cmdline in your question? –  gertvdijk Sep 5 '13 at 12:15

2 Answers 2

Well, you're not alone at least.

MSI GE40 here, with GTX 760M. Exact same issues, optirun works fine and makes a difference, but I can't turn off the discrete card (and it's using most of the power). No /proc/acpi/bbswitch - bbswitch doesn't like to load:

[119624.055053] bbswitch: version 0.7
[119624.055059] bbswitch: Found integrated VGA device 0000:00:02.0: \_SB_.PCI0.GFX0
[119624.055062] bbswitch: cannot find ACPI handle for VGA device 0000:01:00.0
[119624.055064] bbswitch: No discrete VGA device found

If I find a solution I'll be sure to come back here...

Edit: I found this thread,

https://github.com/Bumblebee-Project/bbswitch/issues/65

which tells us it's a kernel bug from kernel 3.8.5-1. Hopefully there'll be a working kernel release again soon. Read that thread if you want to compile up your own kernel, or back the kernel to 3.8.4.

share|improve this answer

I had the same problem. Was using Ubuntu 12.04 LTS with 3.8.0-31-generic kernel (Ubuntu 13.04's kernel). I was able to get optirun and primusrun to both work, but bbswitch will not switch off the discrete GPU automatically after usage.

I managed to get bbswitch to work in the end, by installing the latest v3.11 kernel. Followed the steps on this page: http://itsfoss.com/linux-kernel-3-11-install-in-ubuntu/

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.