Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I like to have my Gnome panel (the one with icons and the Ubuntu menu) on the right side, rather than making my wide-screen even smaller in height.

It worked perfectly except with the "Ambiance" theme, which recently became Ubuntu's default theme:

Graphical bugs when putting Gnome panel on the right side

As you can see, the shadow is repeated vertically, which makes an awful impression of tiles. Other problem, shadows are printed horizontally even though the text is vertical, you can see "14" ad "Fri" shadows in dark behind the vertical text.

Is it a known bug? If not, how to fix it?

share|improve this question
up vote 2 down vote accepted

In the deafult theme, the panel uses an image as the background. This causes problems when you move it around. The simplest way to fix this is just to use a solid background.

Right click the panel, click properties. Select the Background tab and you'll see something a bit like this:

Panel Properties

From there, just select a solid colour, optionally add a bit of transparency, and things should look much better.

share|improve this answer
I had tried this, but actually only the unused spaces get the solid colour. The launchers and applets keep the faulty background, and unfortunately none of them have a "Background" tab in their Preferences. – Nicolas Raoul Apr 4 '11 at 1:00
@Nicolas that's just a caching issue. Logging out, then in again or moving the panel around would fix these graphical glitches. – Oli Apr 4 '11 at 8:40
+1 You're right, that was just a caching issue! In this light, your solution is less invasive, while leading to the same result as Andrei's. The shadow problem for vertical text is still present, by the way. – Nicolas Raoul Apr 4 '11 at 9:59
Strangely, the tiling reappeared when I ran this "killall gnome-panel" after uninstalling indicator-me so I combined with Andrei's solution. – Nicolas Raoul Apr 5 '11 at 12:03

If you use Ubuntu 10.10, to fix Ambiance, run the following command:

gksu gedit /usr/share/themes/Ambiance/gtk-2.0/apps/gnome-panel.rc

And comment line 10 which looks like this: "bg_pixmap[NORMAL] = "img/panel.png"". To comment means to add a "#" sign in front of the line (without the quotes). After editing the file, the line should look like this:

# bg_pixmap[NORMAL] = "img/panel.png"

It's the same for Radiance (but replace "Ambiance" with "Radiance" in the command above).

In Ubuntu 10.04, the file you need to edit is the "gtkrc" file inside the gtkrc-2.0 folder.

Further info: "Fix" The Gnome Panel For Ubuntu 10.10 Maverick Ambiance And Radiance Themes

share|improve this answer
Great article Andrei! The shadow problem for vertical text is still present, but I can live with it. – Nicolas Raoul Apr 4 '11 at 1:13

Oli I just tried the solid colour method you suggested. The panel looks fine at first, but adding the clock leaves you with the same problem. It looks even worse now, and the gradient effect from the OP is still present. This was with the default Ambiance theme in 10.10.

  • EDIT - I just tried the other method and it looks better. A problem remains though. There looks to be a 'drop shadow' of the text that remains horizontal while the lighter text switches to a vertical orientation. You can see this on the OP's image, too. Making the panel much wider looks like a workaround.
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.