Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Sorry to be a complete noob, just installed Ubuntu and I'm trying to get things up and running.

Goal: To connect several drives to my Ubuntu, very old, laptop. This will act as a NAS serving up music, video, and documents for my in home, windows WORKGROUP.

Where I am now:

Ubuntu is running on my laptop. I've installed updates and believe I'm current (but don't know how to check/confirm).

Samba is installed on the Ubuntu laptop. I followed the instructions from many on-line sites and best I can tell it seems to be running correctly. I can see all my windows machines from Home -> browse network -> windows network -> WORKGROUP. All three other computers that are on the workgroup appear and I'm able to go in and see files and such.

So far so good. But that is where I run into trouble.

Remember the point of this fun is to have the Ubuntu box serving the stuff, however...

None of my windows machines can see the Ubuntu laptop on the network. When I go in to My Computer -> Network I see my other two Windows machines but not the Ubuntu laptop. This is happening on both Win 7 and Win 8. Right now it is all hard wired, so wireless is not an issue.

After multiple refreshes, trying all kinds of things, lost sleep the past few nights, and pulling out lots of hair, I've broken down and decided to ask for help. Ya it's a first step.

Anyways, I've looked all over and can't find anything that can help on-line. I must have messed something simple up, so simple that no one bothers to mention it in their walk through. At least I hope so.

Any help you could offer would be, well, helpful.

EDIT #1:

user68186 - I went through the link you provided. I added a new share through the Samba GUI: /home/steve/1-share I checked all the permissions (of course the screens look a bit different) but it loks like everything is correct.

I get stuck here: Step 3. Go to the Windows on the desktop computer and open Windows Explorer, Click on the triangle next to Network on the left panel. From the drop-down list you should be able to select the name of the laptop computer running Ubuntu.

Um, the laptop is just not listed there.

EDIT #2:

Also, I can not see the laptop if I type the IP address into Firefox. "Firefox can't establish a connection to the server at 192.168.1.XXX" (where XXX is the last 3 numbers of course)

EDIT #3:

Thanks Dan, so I typed "\192.168.1.xxx\home/steve/Public" into explorer (this folder is shared in the Samba Server Configuration) and I get the message "Windows cannot access \192.168.1.xxx\home/steve/Public". Just cause I don't know the formats better I also tried "\192.168.1.xxx\home\steve\Public" too but get the same message. Also tried "\192.168.1.109\steve-xxx" and get the same message.

It seems Windows really can't see the laptop.

share|improve this question
    
You have to share at least one folder in Ubuntu for Windows to see it. See askubuntu.com/questions/310180/… –  user68186 Aug 7 '13 at 19:44
    
Is the workgroup of the Ubuntu machine set to WORKGROUP? –  dan08 Aug 7 '13 at 20:42
    
Hi, Yes, the workgroup in Ubuntu's Samba config file is set to WORKGROUP. –  Steve182231 Aug 7 '13 at 20:45
    
Try restarting both machines to make sure new settings are loaded. –  user68186 Aug 7 '13 at 21:49
    
I did a full power off and then power on. Still no joy. –  Steve182231 Aug 7 '13 at 23:16

3 Answers 3

You never told us which version of Windows you're using.

If it's XP, Windows uses "secure file sharing" by default.

This means Samba can't see the machines on the network.

To fix, enable "simple file sharing."

share|improve this answer

I had a similar problem until right now: I was able to connect to my Ubuntu machine through ssh and vnc, but I couldn't see the shared files in "Network" under Windows.

Well, I still cant see them there but I was able to access them by typing

\\192.168.xxx.xx

or

\\pc-name

in windows explorer.

share|improve this answer

I have a similar setup with a Ubuntu machine crammed full of drives in a LAN with Windoze machines. Each drive has a shared folder on it.

When I look under "Network" on the windoze machines the Ubuntu machine does not show up. Until I type "\\ubuntu-machine-name" into the Search box on the windows machine. A file Explorer window opens with the shared folders in it, and the Ubuntu machine is then listed under Network. I can create shortcuts to the shared folders if I like. When I close the file explorer window, the ubuntu machine disappears from the Network listing, but the shortcuts still work.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.