Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My browser updated yesterday and today I've noticed that the option to turn off JavaScript is no longer there. Did they relocate it somewhere? Help.

share|improve this question

closed as off-topic by Eliah Kagan, Radu Rădeanu, Luis Aug 8 '13 at 9:50

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Bug reports and problems with the development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – Eliah Kagan, Radu Rădeanu, Luis
If this question can be reworded to fit the rules in the help center, please edit the question.

1  
Known bug? See Bug 873709 on bugzilla. –  edwin Aug 7 '13 at 19:22
2  
Also read Checkboxes that kill your product. –  edwin Aug 7 '13 at 19:40

1 Answer 1

up vote 2 down vote accepted

The option was intentionally removed in Firefox 23, on the logic that blocking all javascript makes a significant fraction of sites unusable, and so blocking all javascript, everywhere, is seldom desirable behaviour. As the bug report linked by edwin notes, this was a controversial change.

You can blanket disable javascript by going to page about:config and setting the key javascript.enabled to false.

However, if you want to block javascript an extension like NoScript which gives you fine grained control over which scripts run is a better choice.

share|improve this answer
    
Great feature. I am pissed! –  lunar Aug 7 '13 at 20:37

Not the answer you're looking for? Browse other questions tagged or ask your own question.