Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a NVidia GTX 765M video card in my notebook running Ubuntu 12.04.2 and can't figure out why it doesn't use nvidia driver. I've installed nvidia-current and nvidia-settings from this repository:

ppa:ubuntu-x-swat/x-updates

however when I run nvidia-settings this message is shown:

You do not appear to be using the NVIDIA X driver. 
Please edit your X configuration file (just run `nvidia-xconfig` as root),
and restart the X server.

Before run nvidia-xconfig I've looked the /etc/X11/xorg.conf and it is completely empty. After running nvidia-xconfig the scree has as maximum resolution 640x480, and the same message appears when I run nvidia-settings.

ADDED

When I run lspci | grep VGA just Intel card is found:

00:02.0 VGA compatible controller: Intel Corporation Haswell Integrated Graphics Controller (rev 06)

NVidia card is returned when I run lspci | grep 3D:

01:00.0 3D controller: NVIDIA Corporation Device 11e2 (rev a1)

What can I do to make this video card run using nvidia driver?

share|improve this question
    
Most probably your laptop is optimus enabled. Confirm it by executing lspci | grep VGA. If there is two card listed follow this How well do laptops with Nvidia Optimus work? –  Web-E Aug 7 '13 at 18:14
add comment

2 Answers

up vote 0 down vote accepted

This looks like your laptop is using NVidia Optimus, which is often rather troublesome in Linux.
Basically what this means is that the system will use an integrated Intel HD Graphics card by default, and when you tell it to, it will switch to the NVidia card.

I'm not highly knowledgably about the subject, but this is what came to mind.

I think your best option is probably to look in your BIOS/UEFI for an option to use the NVidia card by default, if the issue is indeed NVidia Optimus.

share|improve this answer
    
You're right, the notebook uses optimus technology. I'll try bumblebee... –  brevleq Aug 9 '13 at 0:20
add comment

Please refer to Nvidia Guide. Be sure that in the driver section it stands nvidia and not nv. Also be sure to have all linux headers installed so:

sudo apt-get install linux-headers-generic

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.