Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed Ubuntu a couple days ago. I got it to boot, and it worked fine. However, after troubles with my HDMI (no sound) and presumably my AMD drivers, I decided to install a proprietary driver for AMD Catalyst, which in turn made Ubuntu unusable. To combat this problem, I had Ubuntu delete the old install and reinstall itself. This time, however, I cannot seem to get it to boot correctly. I can boot using the trial from the Live CD, but without the CD I cannot access Ubuntu. I've tried Boot Repair (which for some reason in its advanced options section all of the other options were unavailable to me) and restarted -- that didn't work. Next, I tried to reinstall, once again deleting the old Ubuntu, and still had no luck. I thought maybe my Bios settings were screwing it up, but everything is set so the hard drive boots first. I'm not exactly sure what else I should do.

My PC Specs:
HP tower model: h8-1210t
RAM/Memory: 6Gib (5951Mib)
Processor: Intel(R) Core(TM) i5-2320 CPU @ 3.00GHz
Video Card: Radeon HD 7450 Current installed Ubuntu version: 13.04
Hard Drive Space: 1Tib (921Gib)

I'm not entirely sure what else I should post regarding specs, but I can post any info you need me to if you ask. I've pretty much given up on Ubuntu at this point. It is very lovely, don't get me wrong, but there are sooo many bugs and I can't get anything to work right. If I could, I would love to keep it, but I keep running into problems. Like mentioned before, my HDMI cable. I play a lot of Netflix off my computer, and I have a TV connected via HDMI to my desktop. I am able to get Netflix up and running, everything looks great, but there is no sound being outputted from my TV. The HDMI cable isn't listed in my PulseAudio, nor my regular audio settings. However, this is a problem for a separate thread I suppose. I wish I could just get things to work. I updated the kernel, updated ALSA to the daily build, and everything.. sigh

Thanks for your guys' help, I appreciate it.

EDIT: I was browsing some other answers and decided to input the code

sudo grub-install /dev/sda

What I got was an error code saying this:

Path `/boot/grub' is not readable by GRUB on boot. Installation is impossible. Aborting.

I'm not sure if that means anything to you guys, but I thought maybe it'd help identify the error better.

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.