Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Yesterday I had my Ubuntu Server VM successfully hosting a website that I could access by typing in the IP of the VM (VirtualBox Bridged adapter) in my client's browser. Today I can't access it. I checked ifconfig and got this back for eth0:

eth0     Link encap: Ethernet HWaddr 08:00:27:1b:66:66
         inet6 addr: fe80::aa00:27ff:fe1b:6666/64 Scope:Link
         UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
         RX packets:16 errors:0 dropped:0 overruns:0 carrier:0
         collisions:0 txqueuelen:1000
         RX bytes:0 (0.0 B) TX bytes:3888 (3.8 KB)

There is not inet (IPv4) address being shown for eth0. Why did this disappear and how can I get it back? Yesterday it was 192.168.0.128

EDIT: ping www.google.com returns ping: unknown host www.google.com

share|improve this question
    
Yes, this means that the VM did not receive an IP. What's weird is that it received one yesterday. What you can do is try to reset the interface by ifdown eth0 then ifup eth0, and check if it receives an IP. If it doesn't, what is the output of cat /etc/network/interfaces? –  Alaa Aug 7 '13 at 11:44
add comment

1 Answer

On the VM run:

sudo dhclient

That should make it run out and grab a fresh IP from the router.

I can't say why this has happened. Never had it happen to me.

share|improve this answer
    
Thanks for the reply. If nothing else works I will try doing this, but I would rather have my static IP set otherwise I will have to reconfigure my host's hosts files every time the machine reboots. –  CR47 Aug 7 '13 at 11:36
    
I just tried this and it didn't work. My VM stalled for about 10 minutes. I tried to run the shutdown now command but it said it could not shutdown, shutdown, reboot, etc. commands did not work after this so I was forced to 'reset' the system. I no longer have eth0 show up at all. I think I need a new VM... –  CR47 Aug 7 '13 at 12:12
    
@CR47 I see.. I'd move back to an auto/dhcp configuration and poke the router or dhcp server (depending on your network) for a static IP. It'll be a lot more robust. –  Oli Aug 7 '13 at 12:14
    
I reverted back to dhcp which didn't solve the issue. Tried pinging a few different places, only 127.0.0.1 worked. –  CR47 Aug 7 '13 at 12:18
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.