Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Here is my problem: I only have access to public wireless services.

On occasion I can use a service that does not interfere with Synaptic or apt-get or aptitude: i.e. the provider does not filter certain file types or web sites.

More commonly, say at a public library, anything that is not a .doc, .txt, .pdf, or .htm is blocked, along with a host of often innocent keywords (e.g. anonymizer).

When I use https however, I can download things, since the transaction is private, end to end. I discovered this when I got Tor, which downloads via https by default, and using Tor, I can get mainstream software, like Firefox by directly downloading via https.

What I'd like to do is configure Synaptic software sources to use https as a protocol. I can do this under the other software tab in the software sources application by adding an "s" to the URL. There does not seem to a way to force this for the main repositories, at least not in the GUI.

Apart from adjusting the configuration, there is the question of whether a given mirror honors "https everywhere" (https://www.eff.org/https-everywhere), which in this brave new world strikes me as just common sense.

So how about it? Is there a way to do this? If not, shouldn't it be a priority goal for the near future?

share|improve this question
    
Have you tried editing /etc/apt/sources.list? –  edwin Aug 7 '13 at 4:10
    
Hi and welcome to Ask Ubuntu! The best way to add additional information to your question is by editing it, with the edit button. It is better visible that way, and comments are mainly for secondary, temporary purposes. Comments are removed under a variety of circumstances. Anything important to your question should be in the question itself. –  edwin Aug 11 '13 at 22:57
    
Now, the reason I came here. I tried Edwin's suggestion. It does not work. I am at this time convinced the program software sources (the GUI) does not permit in any manner altering the URLs. The other software alteration I tried reverted as soon as I quit software sources. Editing the file creates persistent changes that are visible in software sources. Using synaptic with the https converted file results in the error text in the subsequent post (in order to force a paragraph. –  user181988 Aug 11 '13 at 23:01
    
W: Failed to fetch us.archive.ubuntu.com/ubuntu/pool/universe/t/twinkle/… Failed to connect to 2001:67c:1562::15: Network is unreachable –  user181988 Aug 11 '13 at 23:02
    
But of course, the network is reachable, and Tor works just fine, so evidently some deeper configuration is needed. This is not actually a technical problem. It is a social problem. It is about access. It is about using technology to defeat barriers. In this case, the technology itself is an additional and unnecessary barrier. –  user181988 Aug 11 '13 at 23:10
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.