Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using a toshiba satellite L655d-S5066 my headphones don't work is there a way to fix them using ubuntu or is this a sacrifice to use ubuntu.

share|improve this question
    
Welcome to Ask Ubuntu! We need more hardware information to help you, can you look at this link and then edit your question adding more detail? askubuntu.com/questions/14008/… –  Jorge Castro Apr 1 '11 at 1:24

2 Answers 2

I found this fix and it worked on the Toshiba Satellite L655D-S5066 Easiest way:

Open a terminal.

Type:

gksu gedit /etc/modprobe.d/alsa-base.conf

Press enter and it will ask for your password.

In gedit, add:

options snd-hda-intel model=ideapad

to the bottom of the file and save it. Be very careful not to change anything else, this instance of gedit is running with superuser permissions and you could damage your installation.

You’ll need to reboot for the changes to take effect.

share|improve this answer

I believe external speakers are disabled by default. Open up terminal and enter

sudo apt-get install gnome-alsamixer

Then enable headphones/external speakers.

share|improve this answer
    
the headphones/external speaker on/off thing does not appear only maste,pcm,beep and 3 microphones –  Abdias Torres Beniquez Apr 8 '11 at 23:10
    
Easiest way: Open a terminal. Type: gksu gedit /etc/modprobe.d/alsa-base.conf Press enter and it will ask for your password. In gedit, add: options snd-hda-intel model=ideapad to the bottom of the file and save it. Be very careful not to change anything else, this instance of gedit is running with superuser permissions and you could damage your installation. You’ll need to reboot for the changes to take effect. –  Abdias Torres Beniquez Apr 22 '11 at 18:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.