Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just tried to install Ubuntu Tweak http://ubuntu-tweak.com/ by downloading and installing the Debian package. Unfortunately I forgot to check its dependencies first, so when I ran

sudo dpkg -i ubuntu-tweak_0.8.5-1_all.deb

I recieved several errors. My terminal output is below:

"..."@"...":~/Downloads$ sudo dpkg -i ubuntu-tweak_0.8.5-1_all.deb
[sudo] password for kyle: 
Selecting previously unselected package ubuntu-tweak.
(Reading database ... 191173 files and directories currently installed.)
Unpacking ubuntu-tweak (from ubuntu-tweak_0.8.5-1_all.deb) ...
dpkg: dependency problems prevent configuration of ubuntu-tweak:
 ubuntu-tweak depends on python-lxml; however:
  Package python-lxml is not installed.
 ubuntu-tweak depends on python-compizconfig; however:
  Package python-compizconfig is not installed.
 ubuntu-tweak depends on gir1.2-unique-3.0; however:
  Package gir1.2-unique-3.0 is not installed.
 ubuntu-tweak depends on gir1.2-gconf-2.0; however:
  Package gir1.2-gconf-2.0 is not installed.
dpkg: error processing ubuntu-tweak (--install):
 dependency problems - leaving unconfigured
Processing triggers for hicolor-icon-theme ...
Processing triggers for gconf2 ...
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processing triggers for desktop-file-utils ...
Processing triggers for gnome-menus ...
Processing triggers for libglib2.0-0 ...
Errors were encountered while processing:
 ubuntu-tweak
"..."@"...":~/Downloads$ 

Ubuntu Tweak now shows up in the Unity Launcher but I have been afraid to try launching it yet since I don't quite know exactly what's been done now. I am not very familiar with Ubuntu yet so I have no idea how to reverse what I did and start over.

Additionally now when I opened Ubuntu Software Centre hoping that I could find a way to remove Ubuntu Tweak I received a message warning that Items wont be able to be installed or removed until the package catalog is repaired. Not wanting to do additional damage I cancelled instead of repairing and closed Software Centre. Now I am wondering what I should do next to reverse or fix all of this and feeling a little out of my depth. Could someone please give me some advice on what I should do?

Thanks!

I am using Ubuntu 12.04 LTS

share|improve this question
    
sudo apt-get -f install worked for me. –  Steve Eynon Aug 29 '13 at 12:23
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.