Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

For some reason, my computer (running Kubuntu netbook edition now, previously UNR) won't connect to my router when it's set to AES+TKIP. As soon as I switch the router to TKIP only, the computer connects.

  1. Should I be concerned about this? Doesn't TKIP bring me back down to the ultimately flawed WPA?
  2. If so, is there a way to get [K]ubuntu to use AES?

EDIT: this is the 10.04 release version of Kubuntu Netbook

Hardware: Asus EeePC 1000H (WiFi chipset: RALINK RT2860)

share|improve this question

closed as too localized by Luis Alvarado Mar 14 '13 at 17:06

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Is this Lucid 10.04 (stable) or Maverick 10.10 (testing)? –  8128 Aug 30 '10 at 6:37
    
@fluteflute: I added version info. –  Jono Aug 30 '10 at 8:26
3  
Are you sure your hardware supports AES? –  Dennis Kaarsemaker Aug 30 '10 at 13:09
    
I would suggest you report a bug on launchpad by running the command ubuntu-bug network-manager-kde –  8128 Aug 30 '10 at 17:29
    
@Dennis of course I'm not sure :) Didn't realise that could be an issue. But I would think relatively modern hardware, like the Asus eeePC 1000H would work, no? –  Jono Aug 30 '10 at 19:53

2 Answers 2

This has everything to do with the RALINK RT2860 chipset (or more its driver) that's embedded in your Asus EeePC 1000H. This thread details upgrading the driver. This might seem a little extreme but from what I've seen of the RT2860, you either upgrade or forget about AES.

There are a few formatting issues, problems with files, etc with that post, so I'm rewriting it here.

  1. Head to http://www.ralinktech.com, hover over software, click linux and look for RT2860 (current string is RT2860PCI/mPCI/CB/PCIe(RT2760/RT2790/RT2860/RT2890), version 2.4.0.0)

  2. Download it and extract it. I had problems extracting it in Gnome. I had to rename it from .tar.bz2 to .tar.gz.

  3. Open a terminal window, cd into the extracted directory.

  4. Edit os/linux/config.mk and change options HAS_WPA_SUPPLICANT and HAS_NATIVE_WPA_SUPPLICANT_SUPPORT to =y

  5. Edit common/cmm_wpa.c (gedit will throw an encoding error - select Western and click retry). Search for MIX_CIPHER_NOTUSE and replace the entire line with this:

    WPA_MIX_PAIR_CIPHER FlexibleCipher = WPA_TKIPAES_WPA2_TKIPAES;
    
  6. It's finally time to compile and install! Yey!

    sudo apt-get install build-essential
    sudo make
    sudo make install
    sudo ifconfig wlan0 down
    sudo rmmod rt2860sta
    
  7. We need to move the old driver out the way. We probably shouldn't delete it in case we need it again so:

    sudo mv /lib/modules/$(uname -r)/kernel/drivers/staging/rt2860/rt2860sta.ko rt2860sta.ko.dist
    

    If you're using a 64bit installation, you might need to change /lib/ to /lib64/

  8. Now we just need to move in the new driver and load it.

    sudo cp os/linux/rt2860sta.ko /lib/modules/$(uname -r)/kernel/drivers/staging/rt2860/
    

    /lib64/... for 64bit installs, again.

    sudo depmod -a
    sudo modprobe rt2860sta
    

    Everything should burst into life. If it doesn't you may need to run sudo ifconfig wlan0 up

  9. For persistence run sudoedit /etc/modules and add rt2860sta as a new line at the end. This will make sure the driver gets loaded at boot.

If it all goes to pot and the new driver doesn't work, just remove the version you copied in and remove the .dist off the old version we renamed.

Note: If you change kernel a lot, you want to invest in some DKMS script to do all this. There may even be deb packages for this driver.

share|improve this answer

This issue has been resolved in Maverick. I just upgraded and it actually works better than before.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.